summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Witschel2019-01-08 00:05:56 +0100
committerJonas Witschel2019-01-08 00:24:23 +0100
commit0acdace799da596b047b36e1df85b898e47dd7e0 (patch)
treeb8cc3f95fced27c887b8a63549d87ab34b42e9dc
parent3979217f6b36bc9767e768e47a45846bc95232de (diff)
downloadaur-0acdace799da596b047b36e1df85b898e47dd7e0.tar.gz
Patch Makefile to work with autoconf-archive 2019.01.06
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
-rw-r--r--initcpio_hooks_tpm2-totp2
3 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6edd41c33259..5ad067c40bcb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = tpm2-totp-git
pkgdesc = Attest the trustworthiness of a device against a human using time-based one-time passwords
pkgver = r8.f9822b9
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/AndreasFuchsSIT/tpm2-totp
arch = x86_64
license = BSD
@@ -22,7 +22,7 @@ pkgbase = tpm2-totp-git
source = initcpio_hooks_tpm2-totp
sha512sums = SKIP
sha512sums = 33738cb9d30d6ad338b6cf6bca538ba4f9b49b9ae799626efc7462bb2a31e386cd04d8298e8c2e3743f4c212866e864332869e4393871f22360edc2567fad163
- sha512sums = cfe75f46018ce254991288ef701381e200a646ef8b9bbca3dd93ab9a862a6e94fd5e519245fb59427ecf73140e419302b4eb81e8134683dfd89660b847ce3538
+ sha512sums = ebce4c738012dbcb82513b1f8148ee17deb088f80fa4f365d1b5f34b9c57f28b1995b4e6d04e003fd2ef6ed3393fb0c4496d182b02a7f5b2609b2ed4a160dac1
pkgname = tpm2-totp-git
diff --git a/PKGBUILD b/PKGBUILD
index 958d464f3155..272bead99de4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jonas Witschel <diabonas at gmx dot de>
pkgname=tpm2-totp-git
pkgver=r8.f9822b9
-pkgrel=1
+pkgrel=2
pkgdesc='Attest the trustworthiness of a device against a human using time-based one-time passwords'
arch=('x86_64')
url='https://github.com/AndreasFuchsSIT/tpm2-totp'
@@ -17,7 +17,7 @@ source=("git+$url.git"
'initcpio_hooks_tpm2-totp')
sha512sums=('SKIP'
'33738cb9d30d6ad338b6cf6bca538ba4f9b49b9ae799626efc7462bb2a31e386cd04d8298e8c2e3743f4c212866e864332869e4393871f22360edc2567fad163'
- 'cfe75f46018ce254991288ef701381e200a646ef8b9bbca3dd93ab9a862a6e94fd5e519245fb59427ecf73140e419302b4eb81e8134683dfd89660b847ce3538')
+ 'ebce4c738012dbcb82513b1f8148ee17deb088f80fa4f365d1b5f34b9c57f28b1995b4e6d04e003fd2ef6ed3393fb0c4496d182b02a7f5b2609b2ed4a160dac1')
BUILDENV+=('!check') # see warning below before enabling tests
pkgver() {
@@ -27,6 +27,7 @@ pkgver() {
prepare() {
cd "${pkgname%-git}"
+ sed --in-place 's|@CODE_COVERAGE_RULES@|include $(top_srcdir)/aminclude_static.am|' Makefile.am
autoreconf --install --force
}
diff --git a/initcpio_hooks_tpm2-totp b/initcpio_hooks_tpm2-totp
index cd45a4529636..bbc3105f109f 100644
--- a/initcpio_hooks_tpm2-totp
+++ b/initcpio_hooks_tpm2-totp
@@ -2,7 +2,7 @@
run_hook() {
echo 'Verification TOTP:'
- tpm2-totp ${tpm2_totp_nvindex:+--nvindex} $tpm2_totp_nvindex --time calculate
+ tpm2-totp ${tpm2_totp_nvindex:+--nvindex "$tpm2_totp_nvindex"} --time calculate
}
# vim: set ft=sh ts=4 sw=4 et: