summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Witschel2019-04-18 10:26:25 +0200
committerJonas Witschel2019-04-18 10:26:25 +0200
commit36fb2a73a4ab6b197bd647a925e41f561084b80f (patch)
tree4f4a258791d014b546de6198d1a6a926143e173f
parenta0a7914bcccd79a30a83296d87491bafb024878a (diff)
downloadaur-36fb2a73a4ab6b197bd647a925e41f561084b80f.tar.gz
Simplify pkgver()
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d1e974eae6db..93edeb067345 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = tpm2-totp-git
pkgdesc = Attest the trustworthiness of a device against a human using time-based one-time passwords
- pkgver = 0.1.0.r5.ed86a39
+ pkgver = 0.1.0.r7.04ca7a6
pkgrel = 1
url = https://github.com/tpm2-software/tpm2-totp
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 25a447dd5d05..8446d20b6ff7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Jonas Witschel <diabonas at gmx dot de>
pkgname=tpm2-totp-git
-pkgver=0.1.0.r5.ed86a39
+pkgver=0.1.0.r7.04ca7a6
pkgrel=1
pkgdesc='Attest the trustworthiness of a device against a human using time-based one-time passwords'
arch=('x86_64')
@@ -22,7 +22,7 @@ BUILDENV+=('!check') # see warning below before enabling tests
pkgver() {
cd "${pkgname%-git}"
- printf '%s' "$(git describe --long | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g')"
+ git describe --long | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g'
}
prepare() {