summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Witschel2019-05-07 22:49:02 +0200
committerJonas Witschel2019-05-07 22:49:02 +0200
commitb52dc5f9ca74039891642f381c479c79f16d2b1a (patch)
tree3cbd78712441751c09613b92577a9a44e3081ffa
parent336d0acd769cf85aa92f1c0f7508a6d351f792e0 (diff)
downloadaur-b52dc5f9ca74039891642f381c479c79f16d2b1a.tar.gz
upgpkg: tpm2-totp-git 0.1.0.r23.bed3c92-1
Upstream now provides optional plymouth integration.
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD14
2 files changed, 14 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7b38333bde41..494acc8e8752 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = tpm2-totp-git
pkgdesc = Attest the trustworthiness of a device against a human using time-based one-time passwords
- pkgver = 0.1.0.r20.ac23908
+ pkgver = 0.1.0.r23.bed3c92
pkgrel = 1
url = https://github.com/tpm2-software/tpm2-totp
arch = x86_64
@@ -8,14 +8,17 @@ pkgbase = tpm2-totp-git
checkdepends = ibm-sw-tpm2
checkdepends = iproute2
checkdepends = oath-toolkit
+ checkdepends = procps-ng
checkdepends = psmisc
checkdepends = tpm2-tools-git
makedepends = git
makedepends = autoconf-archive
makedepends = pandoc
+ makedepends = plymouth
depends = qrencode
depends = tpm2-tss
- optdepends = mkinitcpio: hook to display the TOTP during boot
+ optdepends = mkinitcpio: display the TOTP during boot
+ optdepends = plymouth: display the TOTP during boot
provides = tpm2-totp
conflicts = tpm2-totp
source = git+https://github.com/tpm2-software/tpm2-totp.git
diff --git a/PKGBUILD b/PKGBUILD
index c9a064bd1365..aab438c452ba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,16 @@
# Maintainer: Jonas Witschel <diabonas at gmx dot de>
pkgname=tpm2-totp-git
-pkgver=0.1.0.r20.ac23908
+pkgver=0.1.0.r23.bed3c92
pkgrel=1
pkgdesc='Attest the trustworthiness of a device against a human using time-based one-time passwords'
arch=('x86_64')
url='https://github.com/tpm2-software/tpm2-totp'
license=('BSD')
depends=('qrencode' 'tpm2-tss')
-makedepends=('git' 'autoconf-archive' 'pandoc')
-checkdepends=('ibm-sw-tpm2' 'iproute2' 'oath-toolkit' 'psmisc' 'tpm2-tools-git')
-optdepends=('mkinitcpio: hook to display the TOTP during boot')
+makedepends=('git' 'autoconf-archive' 'pandoc' 'plymouth')
+checkdepends=('ibm-sw-tpm2' 'iproute2' 'oath-toolkit' 'procps-ng' 'psmisc' 'tpm2-tools-git')
+optdepends=('mkinitcpio: display the TOTP during boot'
+ 'plymouth: display the TOTP during boot')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=("git+$url.git")
@@ -28,7 +29,10 @@ prepare() {
build() {
cd "${pkgname%-git}"
(( CHECKFUNC )) && _opts=('--enable-integration')
- ./configure --prefix=/usr --with-mkinitcpiodir=/usr/lib/initcpio "${_opts[@]}"
+ ./configure --prefix=/usr \
+ --libexecdir=/usr/lib \
+ --with-mkinitcpiodir=/usr/lib/initcpio \
+ "${_opts[@]}"
make
}