summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Witschel2019-05-28 13:32:20 +0200
committerJonas Witschel2019-05-28 13:32:20 +0200
commitc8ca2ac63a6effa53c002caf597e175d5a57efb9 (patch)
treea1c103fcad71c393d4c01cdd1f4a5dd98a3d86b9
parente0cd14ce4dc1377e6031def41890862c319a20e5 (diff)
downloadaur-c8ca2ac63a6effa53c002caf597e175d5a57efb9.tar.gz
upgpkg: tpm2-totp-git 0.1.0.r42.a1915e8-1
Add configuration for new dracut module
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5302a04f882a..57b8f4011205 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = tpm2-totp-git
pkgdesc = Attest the trustworthiness of a device against a human using time-based one-time passwords
- pkgver = 0.1.0.r35.8fdb503
+ pkgver = 0.1.0.r42.a1915e8
pkgrel = 1
url = https://github.com/tpm2-software/tpm2-totp
arch = x86_64
@@ -18,8 +18,8 @@ pkgbase = tpm2-totp-git
makedepends = plymouth
depends = qrencode
depends = tpm2-tss
- optdepends = mkinitcpio: display the TOTP during boot
- optdepends = plymouth: display the TOTP during boot
+ optdepends = initramfs: initramfs hooks to display the TOTP during boot
+ optdepends = plymouth: display the TOTP during boot using plymouth messages
provides = tpm2-totp
conflicts = tpm2-totp
source = git+https://github.com/tpm2-software/tpm2-totp.git
diff --git a/PKGBUILD b/PKGBUILD
index d94737819d1f..ab40905a7752 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Jonas Witschel <diabonas at gmx dot de>
pkgname=tpm2-totp-git
-pkgver=0.1.0.r35.8fdb503
+pkgver=0.1.0.r42.a1915e8
pkgrel=1
pkgdesc='Attest the trustworthiness of a device against a human using time-based one-time passwords'
arch=('x86_64')
@@ -9,8 +9,8 @@ license=('BSD')
depends=('qrencode' 'tpm2-tss')
makedepends=('git' 'autoconf-archive' 'pandoc' 'plymouth')
checkdepends=('ibm-sw-tpm2' 'iproute2' 'mkinitcpio' 'oath-toolkit' 'procps-ng' 'psmisc' 'tpm2-tools')
-optdepends=('mkinitcpio: display the TOTP during boot'
- 'plymouth: display the TOTP during boot')
+optdepends=('initramfs: initramfs hooks to display the TOTP during boot'
+ 'plymouth: display the TOTP during boot using plymouth messages')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=("git+$url.git")
@@ -31,6 +31,7 @@ build() {
(( CHECKFUNC )) && _opts=('--enable-integration')
./configure --prefix=/usr \
--libexecdir=/usr/lib \
+ --with-dracutmodulesdir=/usr/lib/dracut/modules.d \
--with-mkinitcpiodir=/usr/lib/initcpio \
"${_opts[@]}"
make