summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Witschel2019-04-18 10:26:25 +0200
committerJonas Witschel2019-04-18 10:26:25 +0200
commit666fae49e450ddc3e0727c1fc6e1376232baa765 (patch)
tree01272fa6c4a7d807e7a121e617556df2821632ac
parentc76559b78288b1e042e050864fb7335961b78a7a (diff)
downloadaur-666fae49e450ddc3e0727c1fc6e1376232baa765.tar.gz
Simplify pkgver()
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cc235380054b..8bf24b6bc12c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = tpm2-tss-git
pkgdesc = Implementation of the TCG Trusted Platform Module 2.0 Software Stack (TSS2)
- pkgver = 2.0.0.r268.79d31052
+ pkgver = 2.0.0.r292.e341d5db
pkgrel = 1
url = https://github.com/tpm2-software/tpm2-tss
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 7e7f3e287502..89082081594c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jonas Witschel <diabonas at gmx dot de>
# Contributor: Hexchain Tong <i at hexchain dot org>
pkgname=tpm2-tss-git
-pkgver=2.0.0.r268.79d31052
+pkgver=2.0.0.r292.e341d5db
pkgrel=1
pkgdesc='Implementation of the TCG Trusted Platform Module 2.0 Software Stack (TSS2)'
arch=('x86_64')
@@ -18,7 +18,7 @@ sha512sums=('SKIP')
pkgver() {
cd "${pkgname%-git}"
- printf '%s' "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+ git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g'
}
prepare() {