summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Witschel2019-01-15 00:18:39 +0100
committerJonas Witschel2019-01-15 00:18:39 +0100
commitd39543cdf4f55f25a3646af671c9fed8b3b643d6 (patch)
tree97618538b05767162fa96515d74ff6f158caaae5
parente2d697d58830ea87f53b42e3445b46de469b2c1d (diff)
downloadaur-d39543cdf4f55f25a3646af671c9fed8b3b643d6.tar.gz
Simplify duplicate ./configure call
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2af27abecace..1ac742e41363 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = tpm2-tss-git
- pkgdesc = Implementation of the Trusted Platform Module 2.0 Software Stack (TSS2)
- pkgver = 2.0.0.r152.311acb02
+ pkgdesc = Implementation of the TCG Trusted Platform Module 2.0 Software Stack (TSS2)
+ pkgver = 2.0.0.r161.17a670dd
pkgrel = 1
url = https://github.com/tpm2-software/tpm2-tss
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 794dc264e9ca..a085c963fb80 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Jonas Witschel <diabonas at gmx dot de>
# Contributor: Hexchain Tong <i at hexchain dot org>
pkgname=tpm2-tss-git
-pkgver=2.0.0.r152.311acb02
+pkgver=2.0.0.r161.17a670dd
pkgrel=1
-pkgdesc='Implementation of the Trusted Platform Module 2.0 Software Stack (TSS2)'
+pkgdesc='Implementation of the TCG Trusted Platform Module 2.0 Software Stack (TSS2)'
arch=('x86_64')
url='https://github.com/tpm2-software/tpm2-tss'
license=('BSD')
@@ -29,13 +29,13 @@ prepare() {
build() {
cd "${pkgname%-git}"
- ./configure --prefix=/usr --with-udevrulesprefix=60-
+ (( CHECKFUNC )) && opts=('--enable-unit' '--enable-integration')
+ ./configure --prefix=/usr --with-udevrulesprefix=60- "${opts[@]}"
make
}
check() {
cd "${pkgname%-git}"
- ./configure --prefix=/usr --with-udevrulesprefix=60- --enable-unit --enable-integration
make check
}
@@ -43,5 +43,5 @@ package() {
cd "${pkgname%-git}"
make DESTDIR="$pkgdir" install
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- echo 'u tss - "tpm2-tss udev rules"' | install -Dm644 /dev/stdin "$pkgdir/usr/lib/sysusers.d/$pkgname.conf"
+ echo 'u tss - "tss user for tpm2"' | install -Dm644 /dev/stdin "$pkgdir/usr/lib/sysusers.d/$pkgname.conf"
}