summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCorey Hinshaw2020-03-07 19:35:17 -0500
committerCorey Hinshaw2020-03-07 19:35:17 -0500
commit1464ce4bab844e935162d71474f28883e9f86130 (patch)
tree1aaa19313522d098aab17e55bef32f5ec08ab940
downloadaur-1464ce4bab844e935162d71474f28883e9f86130.tar.gz
Initial commit - version 1.2
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD24
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..28c0b68f9322
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = tpm_futurepcr
+ pkgdesc = Calculate future TPM PCRs after a kernel upgrade
+ pkgver = 1.2
+ pkgrel = 1
+ url = https://github.com/grawity/tpm_futurepcr
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = python-signify
+ depends = tpm2-tools
+ source = https://github.com/grawity/tpm_futurepcr/archive/v1.2.tar.gz
+ sha256sums = 6eea2b6a9f052f67df354b9badc133878a7f023340e540ad16e80966736b8d8a
+
+pkgname = tpm_futurepcr
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0cced017d91a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.xz
+*.tar.gz
+/pkg
+/src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..91c2ae8f632b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Corey Hinshaw <corey(at)electrickite(dot)org>
+
+pkgname=tpm_futurepcr
+pkgver=1.2
+pkgrel=1
+pkgdesc='Calculate future TPM PCRs after a kernel upgrade'
+arch=('any')
+url="https://github.com/grawity/${pkgname}"
+license=('MIT')
+depends=('python' 'python-signify' 'tpm2-tools')
+makedepends=('python-setuptools')
+
+source=("https://github.com/grawity/${pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('6eea2b6a9f052f67df354b9badc133878a7f023340e540ad16e80966736b8d8a')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}