summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKuoi2022-03-25 02:16:49 +0000
committerKuoi2022-03-25 02:16:49 +0000
commitd37689f1fa9fbac37aeb10c5642e72c5d0b6e89d (patch)
treeef4dddd0f916fc7e6a6ef86d4e39283bf232e542
parent7d083ea93cb97168adbcb43af3bd279709882385 (diff)
downloadaur-d37689f1fa9fbac37aeb10c5642e72c5d0b6e89d.tar.gz
build from official
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b13a6919b536..46250d3b785c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,15 +5,15 @@ pkgbase = tpsutil
url = http://sbmorphometrics.org/soft-utility.html
arch = any
license = custom
+ makedepends = innoextract
depends = wine
depends = wine_gecko
depends = wine-mono
- source = https://github.com/starsareintherose/tpsUtil/releases/download/1.81/tpsUtil.zip
+ source = https://sbmorphometrics.org/morphmet/tpsutilw64.exe
source = tpsUtil.desktop
source = tpsUtil.png
- md5sums = ef07f3ff1dcdb72b253a192f1861c6c9
+ md5sums = 1f72cbb8bf720f3f192b6f8847237e92
md5sums = 64baf6b610dcecc53a15342218579d18
md5sums = 6e52ff5a9df8898532610845c973b23a
pkgname = tpsutil
-
diff --git a/PKGBUILD b/PKGBUILD
index 3ad7230daf85..6ca007ebf893 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,19 +8,22 @@ pkgdesc="tps file utility program"
arch=('any')
url="http://sbmorphometrics.org/soft-utility.html"
license=('custom')
+makedepends=('innoextract')
depends=(
'wine'
'wine_gecko'
'wine-mono'
)
-source=("https://github.com/starsareintherose/tpsUtil/releases/download/${pkgver}/tpsUtil.zip" "tpsUtil.desktop" "tpsUtil.png")
-md5sums=('ef07f3ff1dcdb72b253a192f1861c6c9'
+source=("https://sbmorphometrics.org/morphmet/tpsutilw64.exe" "tpsUtil.desktop" "tpsUtil.png")
+md5sums=('1f72cbb8bf720f3f192b6f8847237e92'
'64baf6b610dcecc53a15342218579d18'
'6e52ff5a9df8898532610845c973b23a')
-
+build(){
+ innoextract tpsutilw64.exe
+}
package() {
install -dm755 "$pkgdir"/usr/share/{tpsutil,applications}
- mv "$srcdir"/tpsUtil/* "$pkgdir"/usr/share/tpsutil
+ mv "$srcdir"/app/* "$pkgdir"/usr/share/tpsutil
install -Dm755 ${srcdir}/tpsUtil.png ${pkgdir}/usr/share/tpsutil/tpsUtil.png
install -Dm755 ${srcdir}/tpsUtil.desktop ${pkgdir}/usr/share/applications/tpsUtil.desktop
}