summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraksr2015-11-28 07:59:28 +0100
committeraksr2015-11-28 07:59:28 +0100
commitc94f5075d12efe99ef60aa1d147aa19c7a09c1e6 (patch)
treebbb14f016cb6b6161b41214cd177a6f2ff7dc477
parent84acb7c33bc7ef62415b860628e5f0e6b64cd4d3 (diff)
downloadaur-c94f5075d12efe99ef60aa1d147aa19c7a09c1e6.tar.gz
Create and add a license file.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1b1cef868804..984206ac26b5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = tr2latex
pkgdesc = Translate troff source to LaTeX
pkgver = 2.4
- pkgrel = 1
+ pkgrel = 2
url = http://www.ctan.org/tex-archive/support/tr2latex
install = tr2latex.install
arch = i686
arch = x86_64
- license = publicdomain
+ license = custom:publicdomain
source = http://www.ctan.org/tex-archive/support/tr2latex.zip
source = tr2latex.install
md5sums = e5b6e9181ff76c7ad8d631feafce5123
diff --git a/PKGBUILD b/PKGBUILD
index ea3a76cca5a6..3677ba71004f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: aksr <aksr at t-com dot me>
pkgname=tr2latex
pkgver=2.4
-pkgrel=1
+pkgrel=2
epoch=
pkgdesc="Translate troff source to LaTeX"
arch=('i686' 'x86_64')
url="http://www.ctan.org/tex-archive/support/tr2latex"
-license=('publicdomain')
+license=('custom:publicdomain')
groups=()
depends=()
makedepends=()
@@ -44,5 +44,11 @@ package() {
cd "$srcdir/$pkgname"
make PREFIX="$pkgdir/usr" \
TEXDIR="$pkgdir/usr/share/texmf-dist/tex/latex/$pkgname" install
+
+ ## a quick-and-ugly™ hack to create a license file:
+ sed '5,21!d' README > LICENSE
+ sed '24,33!d' README >> LICENSE
+ sed '52,56!d' README >> LICENSE
+ install -Dm644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
}