summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan J. Betz2015-06-08 18:05:50 +0200
committerStefan J. Betz2015-06-08 18:05:50 +0200
commitbf2c8528c19394efa3f390a08e030a92bc2e4481 (patch)
tree7e170df5728c3c1f3d92d001108939878e9b9fbf
downloadaur-bf2c8528c19394efa3f390a08e030a92bc2e4481.tar.gz
Initial Import from old AUR.
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD20
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1f3a61581d30
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = trac-mercurial
+ pkgdesc = Mercurial plugin for Trac
+ pkgver = 1.0.0.1
+ pkgrel = 1
+ url = http://trac.edgewall.org/wiki/TracMercurial
+ arch = any
+ license = GPL2
+ makedepends = mercurial
+ depends = setuptools
+ depends = trac>=1.0
+
+pkgname = trac-mercurial
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a4fbea21a633
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Stefan Betz <info@stefan-betz.net>
+# Contributor: Daniele Paolella <dp@hostess-promoter.com>
+pkgname=trac-mercurial
+pkgver=1.0.0.1
+pkgrel=1
+pkgdesc="Mercurial plugin for Trac"
+arch=('any')
+url="http://trac.edgewall.org/wiki/TracMercurial"
+license=('GPL2')
+depends=('setuptools' 'trac>=1.0')
+makedepends=('mercurial')
+
+build() {
+ cd "$srcdir"
+ hg clone http://hg.edgewall.org/trac/mercurial-plugin#1.0
+ cd mercurial-plugin
+ python2 setup.py install --prefix=/usr --root="$pkgdir"
+ mkdir -p "$pkgdir/usr/share/doc/trac-mercurial"
+ install README "$pkgdir/usr/share/doc/trac-mercurial"
+}