summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrii Melnykov2020-04-15 23:30:04 +0000
committerAndrii Melnykov2020-04-15 23:30:04 +0000
commitccfedeee2ab025d5996ceff67fffeb31be3995cf (patch)
tree843b1b4d1cb11760e49b303a6c4ad2778d15c7e3
parente0360c4795f41daf35acb2bbdbfd4a0b324ed3eb (diff)
downloadaur-ccfedeee2ab025d5996ceff67fffeb31be3995cf.tar.gz
Update to TracMercurial-1.0.0.9-1
-rw-r--r--PKGBUILD22
1 files changed, 13 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5b5724792c13..aa39ea59c864 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,24 @@
# Maintainer: Stefan Betz <info@stefan-betz.net>
# Contributor: Daniele Paolella <dp@hostess-promoter.com>
pkgname=trac-mercurial
-pkgver=1.0.0.4
+_name=TracMercurial
+pkgver=1.0.0.9
pkgrel=1
pkgdesc="Mercurial plugin for Trac"
arch=('any')
url="http://trac.edgewall.org/wiki/TracMercurial"
license=('GPL2')
-depends=('setuptools' 'trac>=1.0')
-makedepends=('mercurial')
+depends=('python2-setuptools' 'trac>=1.0' 'mercurial')
+source=("https://pypi.io/packages/source/T/$_name/$_name-$pkgver.tar.gz")
+md5sums=('51f151c7d10ae2b7a1e3b67a4b427e5b')
build() {
- cd "$srcdir"
- hg clone http://hg.edgewall.org/trac/mercurial-plugin#1.0
- cd mercurial-plugin
- python2 setup.py install --prefix=/usr --root="$pkgdir"
- mkdir -p "$pkgdir/usr/share/doc/trac-mercurial"
- install README "$pkgdir/usr/share/doc/trac-mercurial"
+ cd "$srcdir/$_name-$pkgver"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/$_name-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+ install -Dm0644 README "$pkgdir/usr/share/doc/trac-mercurial"
}