summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTroy Engel2019-07-19 07:58:15 -0500
committerTroy Engel2019-07-19 07:58:15 -0500
commitd0913fea414ed795fdcc1c5c86a00fb030ec024d (patch)
treef8f14359c6ce63777cecb09a54617c706d0ea873
parent75daff3d06ed4bbd0c47491c6fc3cb4f53feee6c (diff)
downloadaur-d0913fea414ed795fdcc1c5c86a00fb030ec024d.tar.gz
revert to python2 for plugins, update to match latest git
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD39
2 files changed, 15 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 781b8b5976b1..e7df0bf9cb14 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = trace-cmd-git
pkgdesc = user-space front-end command-line tool for Ftrace, inclduing the GUI interface application kernelshark as well as trace-graph and trace-view.
- pkgver = 2.7.r406.gb43f658
+ pkgver = 2.7.r451.gf1ef911
pkgrel = 1
url = http://git.kernel.org/?p=linux/kernel/git/rostedt/trace-cmd.git
arch = x86_64
arch = aarch64
license = GPL2
- makedepends = python
+ makedepends = python2
makedepends = git
makedepends = docbook-xsl
makedepends = asciidoc
@@ -18,7 +18,7 @@ pkgbase = trace-cmd-git
makedepends = json-c
makedepends = libxmu
makedepends = swig
- optdepends = python: for the python plugins
+ optdepends = python2: for the python plugins
optdepends = qt5-base: for the kernelshark GUI
optdepends = freeglut: for the kernelshark GUI
optdepends = glu: for the kernelshark GUI
diff --git a/PKGBUILD b/PKGBUILD
index 70f69ba7d5d3..ca14fbcd22d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,21 @@
# Maintainer: Nikolay Amiantov <nikoamia@gmail.com>
# Maintainer: Netanel Shine <netanel at archlinux.org.il>
+##
+# Upstream is using python2-only functions like PyString_FromString
+# Ex: trace-cmd/python/ctracecmd.i
+##
+
pkgname=trace-cmd-git
-pkgver=2.7.r406.gb43f658
+pkgver=2.7.r451.gf1ef911
pkgrel=1
pkgdesc="user-space front-end command-line tool for Ftrace, inclduing the GUI interface application kernelshark as well as trace-graph and trace-view."
arch=('x86_64' 'aarch64')
url="http://git.kernel.org/?p=linux/kernel/git/rostedt/trace-cmd.git"
license=('GPL2')
-makedepends=('python' 'git' 'docbook-xsl' 'asciidoc' 'extra-cmake-modules'
+makedepends=('python2' 'git' 'docbook-xsl' 'asciidoc' 'extra-cmake-modules'
'doxygen' 'freeglut' 'glu' 'qt5-base' 'json-c' 'libxmu' 'swig')
-optdepends=('python: for the python plugins'
+optdepends=('python2: for the python plugins'
'qt5-base: for the kernelshark GUI'
'freeglut: for the kernelshark GUI'
'glu: for the kernelshark GUI')
@@ -31,38 +36,18 @@ pkgver() {
sed -r 's/^trace.cmd.v//; s/([^-]*-g)/r\1/;s/-/./g'
}
-prepare() {
- cd "$srcdir/trace-cmd"
-
- ## fixes for getting kernelshark installed correctly to /usr
-
- # pass down Release as build type to strip build directories
- # from final binaries
- sed -i.cip 's|\(-D_INSTALL_PREFIX=\)|-DCMAKE_BUILD_TYPE=Release \1|g' \
- Makefile
-
- # all work below is within kernel-shark/
- cd kernel-shark
-
- # the build sets TRACECMD_BIN_DIR=(local build path) instead of /usr/bin/
- sed -i.tb 's|@TRACECMD_BIN_DIR@|@_INSTALL_PREFIX@/bin|g' build/deff.h.cmake
-
- # the gcc/g++ debug flag is enabled even when _DEBUG=0 which causes
- # the build directory to get coded into the libraries
- sed -i.dbg 's/-Wall -g/-Wall/g' CMakeLists.txt
-}
-
build() {
cd "$srcdir/trace-cmd"
# pkg-config --cflags --libs $PYTHON_VERS
- make PYTHON_VERS=python3 prefix="/usr" DESTDIR="$pkgdir" all doc gui
+ make BUILD_TYPE=Release PYTHON_VERS=python2 \
+ prefix="/usr" DESTDIR="$pkgdir" all doc gui
}
package() {
cd "${srcdir}/trace-cmd"
# pkg-config --cflags --libs $PYTHON_VERS
- make PYTHON_VERS=python3 prefix="/usr" DESTDIR="$pkgdir" \
- install install_doc install_gui
+ make BUILD_TYPE=Release PYTHON_VERS=python2 \
+ prefix="/usr" DESTDIR="$pkgdir" install install_doc install_gui
}