summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorm1kc (Max Musatov)2015-09-09 17:03:56 +0300
committerm1kc (Max Musatov)2015-09-09 17:03:56 +0300
commit4220d7bd66e5ed73adcab7b086ab5b0dc4858271 (patch)
treefae029d98e97aa58b90be194106a7ca895bfe36b
downloadaur-4220d7bd66e5ed73adcab7b086ab5b0dc4858271.tar.gz
Initial commit.
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD43
-rwxr-xr-xtrack-o-bot.install38
4 files changed, 102 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..03387906b7d9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = track-o-bot-git
+ pkgdesc = Track-o-Bot is a small, easy-to-use app which automatically tracks your Hearthstone matches. No packet sniffing, just parsing HS logs.
+ pkgver = 0.2.1.r138.gb3a6499
+ pkgrel = 1
+ url = https://github.com/BOSSoNe0013/track-o-bot
+ install = track-o-bot.install
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = git
+ depends = qt5-base
+ depends = hicolor-icon-theme
+ source = git://github.com/BOSSoNe0013/track-o-bot.git
+ md5sums = SKIP
+
+pkgname = track-o-bot-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a764fd742610
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src/
+pkg/
+track-o-bot/
+*.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2336c2790a20
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: m1kc (Max Musatov) <m1kc@yandex.ru>
+
+pkgname="track-o-bot-git"
+_pkgname="track-o-bot"
+pkgver=0.2.1.r138.gb3a6499
+pkgrel=1
+pkgdesc="Track-o-Bot is a small, easy-to-use app which automatically tracks your Hearthstone matches. No packet sniffing, just parsing HS logs."
+arch=('i686' 'x86_64')
+url="https://github.com/BOSSoNe0013/track-o-bot"
+license=('LGPL')
+groups=()
+depends=("qt5-base" "hicolor-icon-theme")
+makedepends=('git')
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install="track-o-bot.install"
+source=('git://github.com/BOSSoNe0013/track-o-bot.git')
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "$srcdir/$_pkgname"
+ sed -i 's/Game;/Game;Games;/g' "assets/track-o-bot.desktop"
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ qmake PREFIX=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ make DESTDIR="$pkgdir" INSTALL_ROOT="$pkgdir" install
+}
diff --git a/track-o-bot.install b/track-o-bot.install
new file mode 100755
index 000000000000..f464f8bd7ce8
--- /dev/null
+++ b/track-o-bot.install
@@ -0,0 +1,38 @@
+#!/bin/sh
+
+hsnote() {
+ echo ""
+ echo "FURTHER CONFIGURATION IS NEEDED!"
+ echo "Create folder named .Hearthstone in your home directory."
+ echo "Create symlinks of the Hearthstone's output_log and log.config"
+ echo "in the newly created folder."
+ echo ""
+ echo "You may also need to manually enable Hearthstone logging."
+ echo "More information here:"
+ echo "https://www.reddit.com/r/hearthstone/comments/268fkk/simple_hearthstone_logging_see_your_complete_play"
+ echo ""
+ echo "Don't forget to make sure that the logging actually works"
+ echo "before proceeding."
+ echo ""
+}
+
+upd() {
+ gtk-update-icon-cache
+ update-desktop-database -q
+ update-mime-database usr/share/mime
+}
+
+post_install() {
+ upd
+ hsnote
+}
+
+post_upgrade() {
+ upd
+}
+
+post_remove () {
+ upd
+}
+
+