summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Bruguera2019-03-22 17:33:23 +0100
committerJoan Bruguera2019-03-22 17:33:23 +0100
commit33de112ed33d716f10bd0088b086e19fbbfe2606 (patch)
tree612d8b10456d224e2366c7edd9c966ba2772d246
parente160b350c58dbfe56ee01f8fedef3939a3440706 (diff)
downloadaur-33de112ed33d716f10bd0088b086e19fbbfe2606.tar.gz
Lint and uniformize BSC package files.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD17
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0d4aaecc8821..7b66e4c94eae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = tracking
pkgdesc = Analyze how the behavior of a parallel application evolves through different scenarios (from BSC).
pkgver = 2.6.10
- pkgrel = 1
+ pkgrel = 2
url = https://www.bsc.es/discover-bsc/organisation/scientific-structure/performance-tools
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index ef5bdc5d0768..38340987d7f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname='tracking'
pkgdesc='Analyze how the behavior of a parallel application evolves through different scenarios (from BSC).'
pkgver='2.6.10'
-pkgrel='1'
+pkgrel='2'
arch=('i686' 'x86_64')
url='https://www.bsc.es/discover-bsc/organisation/scientific-structure/performance-tools'
license=('GPLv2')
@@ -11,17 +11,18 @@ source=("https://ftp.tools.bsc.es/$pkgname/$pkgname-$pkgver-src.tar.bz2")
sha512sums=(577783edf85f9a53fdabc8a25556fca806c8a9c3df28d713815fc5cccb63450bf3a5d0ee904bec4e7b125f3278d75e6c2b9c2e899f14ab4694d288b07db3eb9d)
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$pkgname-$pkgver"
- ./configure \
- --prefix=/usr \
- --with-paraver=/usr
+ ./configure \
+ --prefix=/usr \
+ --with-paraver=/usr
- make
+ make
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$pkgname-$pkgver"
- make prefix="$pkgdir/usr/" install # NB: using DESTDIR instead, does not work
+ # WORKAROUND: Specifying the install directory using DESTDIR does not work
+ make prefix="$pkgdir/usr/" install
}