summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Bruguera2020-03-16 16:24:36 +0100
committerJoan Bruguera2020-03-16 16:24:36 +0100
commit5926e9fcfb0bc75f029971dc752c5412c0134f51 (patch)
tree4368f135ddea02364e1ee81081879bb00cd13811
parentd4fe25af71a96e68bf1d33170dfb18b153b267ea (diff)
downloadaur-5926e9fcfb0bc75f029971dc752c5412c0134f51.tar.gz
Update to 2.6.11 (20200316).
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rw-r--r--python3-ports.patch11
3 files changed, 8 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 75e771af2511..e46847a0179f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = tracking
pkgdesc = Analyze how the behavior of a parallel application evolves through different scenarios (from BSC).
- pkgver = 2.6.10.20191212
+ pkgver = 2.6.11.20200316
pkgrel = 1
url = https://www.bsc.es/discover-bsc/organisation/scientific-structure/performance-tools
arch = i686
@@ -11,10 +11,10 @@ pkgbase = tracking
depends = python-pillow
depends = python-wxpython
depends = python-matplotlib
- source = https://ftp.tools.bsc.es/tracking/tracking-2.6.10-src.tar.bz2
+ source = https://ftp.tools.bsc.es/tracking/tracking-2.6.11-src.tar.bz2
source = python3-ports.patch
- sha512sums = 85d269bb8114de4e62ae85db5e3c7afb26fbc9e4c0c048c91eab1868eca74722afb558702d22ac2f2c29f92af2e21d22613b32fd01f7c9681663bcf87b89e5c1
- sha512sums = 78568513919ee9d5e2c1c2a9f835259d097b2bbd246fc911b4c2083d4e2a9e20c86a15e990997b41dd5e62bb04d3c156c2aa47ad90d6d3fc55eca1040fc97ed9
+ sha512sums = 9a9e4bda1d179511aa28bd9e08a8c7a61d6b54a1f392e948514926f54ddd35d7db4f4f39f0c0420cb016e7ff3a016785305a0a0aad4d35ace0ec8ceb129a2911
+ sha512sums = 127d7a1989284ebfd8911090ce01e38fad7dbb12ceb307e73a6fb54dff09f9e0c99410376dce4a8e1e4308dc5c44e25218c929df6151b674b31a06e4e1075bfe
pkgname = tracking
diff --git a/PKGBUILD b/PKGBUILD
index 498583e30d29..33d8df91d9dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Joan Bruguera Micó <joanbrugueram@gmail.com>
pkgname='tracking'
pkgdesc='Analyze how the behavior of a parallel application evolves through different scenarios (from BSC).'
-pkgver='2.6.10.20191212'
+pkgver='2.6.11.20200316'
pkgrel='1'
arch=('i686' 'x86_64')
url='https://www.bsc.es/discover-bsc/organisation/scientific-structure/performance-tools'
@@ -9,8 +9,8 @@ license=('GPL2')
depends=(wxparaver clusteringsuite python-pillow python-wxpython python-matplotlib)
source=("https://ftp.tools.bsc.es/$pkgname/$pkgname-${pkgver%.*}-src.tar.bz2"
python3-ports.patch)
-sha512sums=(85d269bb8114de4e62ae85db5e3c7afb26fbc9e4c0c048c91eab1868eca74722afb558702d22ac2f2c29f92af2e21d22613b32fd01f7c9681663bcf87b89e5c1
- 78568513919ee9d5e2c1c2a9f835259d097b2bbd246fc911b4c2083d4e2a9e20c86a15e990997b41dd5e62bb04d3c156c2aa47ad90d6d3fc55eca1040fc97ed9)
+sha512sums=(9a9e4bda1d179511aa28bd9e08a8c7a61d6b54a1f392e948514926f54ddd35d7db4f4f39f0c0420cb016e7ff3a016785305a0a0aad4d35ace0ec8ceb129a2911
+ 127d7a1989284ebfd8911090ce01e38fad7dbb12ceb307e73a6fb54dff09f9e0c99410376dce4a8e1e4308dc5c44e25218c929df6151b674b31a06e4e1075bfe)
prepare() {
cd "$srcdir/$pkgname-${pkgver%.*}"
diff --git a/python3-ports.patch b/python3-ports.patch
index d6933911a7d0..3f8b4d70c720 100644
--- a/python3-ports.patch
+++ b/python3-ports.patch
@@ -1,5 +1,5 @@
diff --git a/src/scripts/scale-frames.py b/src/scripts/scale-frames.py
-index cadaeb1..f10c60b 100755
+index 38821eb..5f371e2 100755
--- a/src/scripts/scale-frames.py
+++ b/src/scripts/scale-frames.py
@@ -17,8 +17,8 @@ SuffixNormalizedCSV = ".norm"
@@ -30,12 +30,3 @@ index cadaeb1..f10c60b 100755
sys.exit(-1)
InputTraces = [] # array[ TRACE1, TRACE2 ... ]
-@@ -112,7 +112,7 @@ for Trace in sys.argv[currentArg:]:
- CSVFile = TraceBasename + SuffixClustersData
-
- ### Get the number of tasks from the trace
-- Header = subprocess.Popen(["head", "-n1", Trace], shell=False, stdout=subprocess.PIPE).communicate()[0]
-+ Header = subprocess.Popen(["head", "-n1", Trace], shell=False, stdout=subprocess.PIPE).communicate()[0].decode('utf-8')
- numTasks = float(Header.split("(")[2].split(":")[2])
- TasksPerTrace.append(numTasks)
-