summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIvan Gabaldon2023-12-02 13:52:50 +0100
committerIvan Gabaldon2023-12-02 13:52:50 +0100
commit5438f0ace11dceb10d0ff6da03a192be27c7b18a (patch)
tree07f10d5977f6e86aa5ec0b35c7fbe514edb75248
parent3c7ac332524596e9caa9db2d96de00242515061b (diff)
downloadaur-5438f0ace11dceb10d0ff6da03a192be27c7b18a.tar.gz
upgpkg: tradingview 2.7.1-2
-rw-r--r--.SRCINFO34
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD60
-rw-r--r--tradingview.desktop10
4 files changed, 77 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7f6440d4ec64..62693a88f936 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,38 @@
pkgbase = tradingview
- pkgdesc = Experience extra power, extra speed and extra flexibility, all with the same UX you know and love
+ pkgdesc = TradingView is a charting platform for traders and investors
pkgver = 2.7.1
- pkgrel = 1
+ pkgrel = 2
url = https://www.tradingview.com/desktop/
arch = x86_64
- license = custom
+ license = custom:proprietary
+ makedepends = links
makedepends = squashfs-tools
+ depends = alsa-lib
+ depends = at-spi2-core
+ depends = cairo
+ depends = dbus
+ depends = expat
+ depends = gcc-libs
+ depends = glib2
+ depends = glibc
+ depends = gtk3
+ depends = hicolor-icon-theme
+ depends = libcups
+ depends = libdrm
+ depends = libsecret
+ depends = libx11
+ depends = libxcb
+ depends = libxcomposite
+ depends = libxdamage
+ depends = libxext
+ depends = libxfixes
+ depends = libxkbcommon
+ depends = libxrandr
+ depends = mesa
+ depends = nspr
+ depends = nss
+ depends = pango
source = tradingview-2.7.1.snap::https://api.snapcraft.io/api/v1/snaps/download/nJdITJ6ZJxdvfu8Ch7n5kH5P99ClzBYV_48.snap
- source = tradingview.desktop
b2sums = 979958b07225cb2cd0b132d98b7e8727cca2b6fca8fd5608b16f9c9daddbe39c21b9ea94ceac47447c79e97cb6ca15fab63bfe0fadbc8d221ba75cd71dc428f8
- b2sums = 86d4c70928b6c2a4e3e95402be276e2de94216289d9e82c534d92b8a4db15252721c20be7a8828b8f4ba871d50903ba88137e9f5c374c46ff529584b8a7a8a89
pkgname = tradingview
diff --git a/.gitignore b/.gitignore
index a15375ecb260..4367ae4a50ac 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,4 @@
*
!.gitignore
!.SRCINFO
-!PKGBUILD
-!tradingview.desktop \ No newline at end of file
+!PKGBUILD \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index e8b5b99d0c0d..979fb52c6eca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,23 +3,56 @@
pkgname=tradingview
pkgver=2.7.1
-pkgrel=1
-pkgdesc='Experience extra power, extra speed and extra flexibility, all with the same UX you know and love'
+pkgrel=2
+pkgdesc='TradingView is a charting platform for traders and investors'
arch=('x86_64')
url='https://www.tradingview.com/desktop/'
-license=('custom')
-makedepends=('squashfs-tools')
-source=("$pkgname-$pkgver.snap::https://api.snapcraft.io/api/v1/snaps/download/nJdITJ6ZJxdvfu8Ch7n5kH5P99ClzBYV_48.snap"
- "$pkgname.desktop")
-b2sums=('979958b07225cb2cd0b132d98b7e8727cca2b6fca8fd5608b16f9c9daddbe39c21b9ea94ceac47447c79e97cb6ca15fab63bfe0fadbc8d221ba75cd71dc428f8'
- '86d4c70928b6c2a4e3e95402be276e2de94216289d9e82c534d92b8a4db15252721c20be7a8828b8f4ba871d50903ba88137e9f5c374c46ff529584b8a7a8a89')
+license=('custom:proprietary')
+depends=('alsa-lib'
+ 'at-spi2-core'
+ 'cairo'
+ 'dbus'
+ 'expat'
+ 'gcc-libs'
+ 'glib2'
+ 'glibc'
+ 'gtk3'
+ 'hicolor-icon-theme'
+ 'libcups'
+ 'libdrm'
+ 'libsecret'
+ 'libx11'
+ 'libxcb'
+ 'libxcomposite'
+ 'libxdamage'
+ 'libxext'
+ 'libxfixes'
+ 'libxkbcommon'
+ 'libxrandr'
+ 'mesa'
+ 'nspr'
+ 'nss'
+ 'pango')
+makedepends=('links'
+ 'squashfs-tools')
+source=("$pkgname-$pkgver.snap::https://api.snapcraft.io/api/v1/snaps/download/nJdITJ6ZJxdvfu8Ch7n5kH5P99ClzBYV_48.snap")
+b2sums=('979958b07225cb2cd0b132d98b7e8727cca2b6fca8fd5608b16f9c9daddbe39c21b9ea94ceac47447c79e97cb6ca15fab63bfe0fadbc8d221ba75cd71dc428f8')
prepare() {
- mkdir -p "$pkgname-$pkgver"
- unsquashfs -q -n -f -d "$pkgname-$pkgver/" "$pkgname-$pkgver.snap"
+ ## EULA
+ links -width 80 -dump https://www.tradingview.com/policies/ | \
+ sed -n '/Terms of Use, Policies and Disclaimers/,/TradingView may update these Rules at any time./p' > "$srcdir/EULA.txt"
- mv "$pkgname-$pkgver/meta/gui/icon.png" "$srcdir"
- rm -r "$pkgname-$pkgver/"{data-dir/,gnome-platform/,lib/,meta/,scripts/,usr/}
+ ## Extract
+ unsquashfs -q -f -d "$pkgname-$pkgver/" "$pkgname-$pkgver.snap"
+
+ mv "$pkgname-$pkgver/meta/gui/icon.png" "$srcdir/"
+ mv "$pkgname-$pkgver/meta/gui/$pkgname.desktop" "$srcdir/"
+ sed -n -e 's@${SNAP}/meta/gui/icon.png@'"$pkgname"'@g' \
+ -e 's@^Categories=Finance;$@Categories=Office;Finance;@g' \
+ "$srcdir/$pkgname.desktop"
+
+ rm -r "$pkgname-$pkgver/"{data-dir/,gnome-platform/,lib/,meta/,scripts/,usr/,*.sh}
}
package() {
@@ -30,5 +63,6 @@ package() {
ln -s "/opt/$pkgname/$pkgname" "$pkgdir/usr/bin/$pkgname"
install -Dm644 "$srcdir/icon.png" "$pkgdir/usr/share/icons/hicolor/512x512/apps/$pkgname.png"
- install -Dm644 "$srcdir/$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -Dm644 "$srcdir/$pkgname.desktop" -t "$pkgdir/usr/share/applications/"
+ install -Dm644 "$srcdir/EULA.txt" -t "$pkgdir/usr/share/licenses/$pkgname/"
}
diff --git a/tradingview.desktop b/tradingview.desktop
deleted file mode 100644
index 35e1aa781cc1..000000000000
--- a/tradingview.desktop
+++ /dev/null
@@ -1,10 +0,0 @@
-[Desktop Entry]
-Name=TradingView
-Exec=tradingview %U
-Terminal=false
-Type=Application
-Icon=tradingview
-StartupWMClass=TradingView
-Comment=Experience extra power, extra speed and extra flexibility, all with the same UX you know and love.
-MimeType=x-scheme-handler/tradingview;
-Categories=Finance;Office;