summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorInetol2022-11-18 21:45:37 +0100
committerInetol2022-11-18 21:45:37 +0100
commit9c3367865739b13b24c55e7edec967a0c52440c3 (patch)
tree9384841e1e0147078cc34dbac3411f072ae48719
downloadaur-9c3367865739b13b24c55e7edec967a0c52440c3.tar.gz
addpkg: tradingview 1.0.17-1
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD37
-rw-r--r--desktop_entry.patch11
4 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b1975457516d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = tradingview
+ pkgdesc = Experience extra power, extra speed and extra flexibility, all with the same UX you know and love
+ pkgver = 1.0.17
+ pkgrel = 1
+ url = https://www.tradingview.com/desktop/
+ arch = x86_64
+ license = custom
+ makedepends = squashfs-tools
+ conflicts = tradingview-bin
+ source = tradingview-1.0.17.snap::https://api.snapcraft.io/api/v1/snaps/download/nJdITJ6ZJxdvfu8Ch7n5kH5P99ClzBYV_28.snap
+ source = desktop_entry.patch
+ b2sums = 30eebad7a5e9429756fbba88368b5a29937bedead517fed431d9308bf4ad7c0373c5f730201a3f8435a7d761b9598eaa314a7f2e034962fb0194331b879cbb7f
+ b2sums = b7dbd4f2de84d281ae4b93d35ee039f9dad111696f856867e295b4e214bf28c524b350bf6f160992f8d72d3c15a17291f9dee744e0cb7d5d1ab0449fd6b316a3
+
+pkgname = tradingview
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3c039db640e6
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!.SRCINFO
+!desktop_entry.patch
+!PKGBUILD \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..37a6af60c36a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Ivan Gabaldon <ivan [d0t] gab [at] inetol [d0t] net>
+# Contributor: sukanka <su975853527 at gmail.com>
+
+pkgname=tradingview
+pkgver=1.0.17
+pkgrel=1
+pkgdesc='Experience extra power, extra speed and extra flexibility, all with the same UX you know and love'
+arch=('x86_64')
+url='https://www.tradingview.com/desktop/'
+license=('custom')
+makedepends=('squashfs-tools')
+conflicts=("$pkgname-bin")
+source=("$pkgname-$pkgver.snap::https://api.snapcraft.io/api/v1/snaps/download/nJdITJ6ZJxdvfu8Ch7n5kH5P99ClzBYV_28.snap"
+ 'desktop_entry.patch')
+b2sums=('30eebad7a5e9429756fbba88368b5a29937bedead517fed431d9308bf4ad7c0373c5f730201a3f8435a7d761b9598eaa314a7f2e034962fb0194331b879cbb7f'
+ 'b7dbd4f2de84d281ae4b93d35ee039f9dad111696f856867e295b4e214bf28c524b350bf6f160992f8d72d3c15a17291f9dee744e0cb7d5d1ab0449fd6b316a3')
+
+prepare() {
+ mkdir -p "$pkgname-$pkgver"
+ unsquashfs -q -n -f -d "$pkgname-$pkgver/" $pkgname-$pkgver.snap
+
+ mv "$pkgname-$pkgver/meta/gui/"{icon.png,$pkgname.desktop} "$srcdir"
+ rm -r "$pkgname-$pkgver/"{data-dir/,gnome-platform/,lib/,meta/,scripts/,usr/}
+
+ patch -u "$srcdir/$pkgname.desktop" -i "$srcdir/desktop_entry.patch"
+}
+
+package() {
+ install -d "$pkgdir/opt/$pkgname"
+ cp -r "$srcdir/$pkgname-$pkgver/"* "$pkgdir/opt/$pkgname"
+
+ install -d "$pkgdir/usr/bin"
+ ln -s "/opt/$pkgname/$pkgname" "$pkgdir/usr/bin/$pkgname"
+
+ install -Dm644 "$srcdir/icon.png" "$pkgdir/usr/share/icons/hicolor/512x512/apps/$pkgname.png"
+ install -Dm644 "$srcdir/$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+}
diff --git a/desktop_entry.patch b/desktop_entry.patch
new file mode 100644
index 000000000000..6217800d36cc
--- /dev/null
+++ b/desktop_entry.patch
@@ -0,0 +1,11 @@
+--- src/tradingview-1.0.17/meta/gui/tradingview.desktop 2022-10-25 14:59:58.000000000 +0200
++++ tradingview.desktop 2022-11-18 21:10:16.957948720 +0100
+@@ -3,7 +3,7 @@
+ Exec=tradingview %U
+ Terminal=false
+ Type=Application
+-Icon=${SNAP}/meta/gui/icon.png
++Icon=tradingview
+ StartupWMClass=TradingView
+ Comment=Experience extra power, extra speed and extra flexibility, all with the same UX you know and love.
+ MimeType=x-scheme-handler/tradingview;