summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Serajnik2020-02-02 20:54:54 +0100
committerMichael Serajnik2020-02-02 20:54:54 +0100
commit6c2985b6144c015d346655d78bae7709b235aef2 (patch)
tree240ccd3f4ea20e6bfc9c8d640c9c32df5e724949
parenta8749df696c17ac2498c49f92d619c35f9156fa1 (diff)
downloadaur-6c2985b6144c015d346655d78bae7709b235aef2.tar.gz
feat: add optional dependencies for determining download and upload speed
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
2 files changed, 6 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3b5e269861e3..0b89ba238bdd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = traffictoll-git
pkgdesc = NetLimiter-like traffic shaping for Linux
- pkgver = 1.0.2.r0.g0add8b6
+ pkgver = 1.4.0.r2.gf246e76
pkgrel = 1
url = https://github.com/cryzed/TrafficToll
arch = any
@@ -11,6 +11,8 @@ pkgbase = traffictoll-git
depends = python-loguru
depends = python-psutil
depends = python-ruamel-yaml
+ optdepends = speedtest-cli: determine the download and upload speed automatically for traffic prioritization
+ optdepends = ookla-speedtest-bin: determine the download and upload speed automatically for traffic prioritization
conflicts = traffictoll
source = git+https://github.com/cryzed/TrafficToll.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 14de8b89b373..200d9288145a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,15 @@
# Maintainer: Michael Serajnik <ms dot mserajnik dot at>
pkgname=traffictoll-git
_pkgname=TrafficToll
-pkgver=1.0.2.r0.g0add8b6
+pkgver=1.4.0.r2.gf246e76
pkgrel=1
pkgdesc="NetLimiter-like traffic shaping for Linux"
arch=('any')
url="https://github.com/cryzed/${_pkgname}"
license=('GPL3')
depends=('python' 'python-loguru' 'python-psutil' 'python-ruamel-yaml')
+optdepends=('speedtest-cli: determine the download and upload speed automatically for traffic prioritization'
+ 'ookla-speedtest-bin: determine the download and upload speed automatically for traffic prioritization')
makedepends=('python-pip' 'python-poetry')
conflicts=('traffictoll')
source=("git+https://github.com/cryzed/${_pkgname}.git")