summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOliver Bandel2015-06-10 01:08:01 +0200
committerOliver Bandel2015-06-10 01:08:01 +0200
commitc91e6cedbb590d1a7a51927465ef45241f178a09 (patch)
treea58b4eae4d06ba9df2bc17ec1fc33b41f7452c4e
downloadaur-c91e6cedbb590d1a7a51927465ef45241f178a09.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD25
-rw-r--r--trafshow.patch41
3 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f40a8a4b2a85
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by makepkg 4.2.1
+# Mon Mar 23 16:45:37 UTC 2015
+pkgbase = trafshow
+ pkgdesc = Full screen network monitoring
+ pkgver = 5.2.3
+ pkgrel = 5
+ url = http://soft.risp.ru/trafshow/index_en.shtml
+ arch = i686
+ arch = x86_64
+ license = netbsd
+ depends = libpcap
+ depends = ncurses
+ source = http://fossies.org/linux/misc/old/trafshow-5.2.3.tgz
+ source = trafshow.patch
+ md5sums = 0b2f0bb23b7832138b7d841437b9e182
+ md5sums = 4a85997d88dffa27ac469c6429752cb2
+
+pkgname = trafshow
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5d410e6c9e15
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: oliver < a t > first . in-berlin . de
+# Contributor: gunnar <tomtinn@gmail.com>
+pkgname=trafshow
+pkgver=5.2.3
+pkgrel=5
+pkgdesc="Full screen network monitoring"
+arch=('i686' 'x86_64')
+url="http://soft.risp.ru/trafshow/index_en.shtml"
+license=('netbsd')
+depends=('libpcap' 'ncurses')
+source=(http://fossies.org/linux/misc/old/${pkgname}-$pkgver.tgz trafshow.patch)
+md5sums=('0b2f0bb23b7832138b7d841437b9e182' '4a85997d88dffa27ac469c6429752cb2')
+
+build() {
+cd $srcdir/$pkgname-$pkgver
+patch -p1 -i ../trafshow.patch || return 1
+./configure --prefix=/usr
+make || return 1
+}
+
+package() {
+ PKGDIR=$srcdir/$pkgname-$pkgver/../../pkg/$pkgname
+ cd $srcdir/$pkgname-$pkgver
+ make DESTDIR=$PKGDIR install
+}
diff --git a/trafshow.patch b/trafshow.patch
new file mode 100644
index 000000000000..32b96666cd28
--- /dev/null
+++ b/trafshow.patch
@@ -0,0 +1,41 @@
+diff -aur trafshow-5.2.3/Makefile.in trafshow-5.2.3.patched/Makefile.in
+--- trafshow-5.2.3/Makefile.in 2004-06-15 08:29:14.000000000 +0000
++++ trafshow-5.2.3.patched/Makefile.in 2009-11-05 12:46:47.274533717 +0000
+@@ -73,9 +73,9 @@
+ @echo 'char compiled[] = "$(CC) $(CFLAGS) $(LIBS)";' >> $@
+
+ install:
+- ./install-sh -c -s -m 555 -o bin -g bin $(PROG) $(BINDEST)/$(PROG)
+- ./install-sh -c -m 444 -o bin -g bin $(PROG).1 $(MANDEST)/man1/$(PROG).1
+- [ -f /etc/$(PROG) ] || ./install-sh -c -m 444 .trafshow /etc/$(PROG)
++ ./install-sh -c -s -m 555 -o bin -g bin $(PROG) $(DESTDIR)$(BINDEST)/$(PROG)
++ ./install-sh -c -m 444 -o bin -g bin $(PROG).1 $(DESTDIR)$(MANDEST)/man1/$(PROG).1
++ [ -f /etc/$(PROG) ] || ./install-sh -c -m 444 .trafshow $(DESTDIR)/etc/$(PROG)
+
+ clean:
+ rm -f $(CLEANFILES)
+diff -aur trafshow-5.2.3/config.sub trafshow-5.2.3.patched/config.sub
+--- trafshow-5.2.3/config.sub 2004-01-28 08:00:38.000000000 +0000
++++ trafshow-5.2.3.patched/config.sub 2009-11-05 12:34:51.358774674 +0000
+@@ -164,6 +164,9 @@
+ i[3456]86)
+ basic_machine=$basic_machine-pc
+ ;;
++ x86_64*)
++ basic_machine=amd64
++ ;;
+ # Object if more than one company name word.
+ *-*-*)
+ echo Invalid configuration \`$1\': machine \`$basic_machine\' not recognized 1>&2
+diff -aur trafshow-5.2.3/session.c trafshow-5.2.3.patched/session.c
+--- trafshow-5.2.3/session.c 2006-01-08 05:58:08.000000000 +0000
++++ trafshow-5.2.3.patched/session.c 2009-11-05 12:34:51.361276949 +0000
+@@ -40,7 +40,7 @@
+ #define ASYNC_MODE FNDELAY
+ #elif O_ASYNC
+ #define ASYNC_MODE O_ASYNC
+-#elif
++/*#elif*/
+ #error the fcntl argument to turn ON/OFF non-blocking I/O is unknown
+ #endif
+