summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMubashshir2020-06-07 15:33:22 +0600
committerMubashshir2020-06-07 15:33:22 +0600
commit6ea8bd53e3c4a752454241145c01283b5fced84d (patch)
tree6bf8329986668dc92f70616548c8725ea15c9315
parent93d2eb244e793602045110bbe0028b6c24f7c475 (diff)
downloadaur-6ea8bd53e3c4a752454241145c01283b5fced84d.tar.gz
update.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 906f5a9c9b9d..90dea747aa5e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = trakt-scrobbler
pkgdesc = Automatically scrobble TV show episodes and movies you are watching to Trakt.tv! It keeps a history of everything you've watched!
pkgver = 1.0.0b6
- pkgrel = 0
+ pkgrel = 1
url = https://github.com/iamkroot/trakt-scrobbler
arch = any
license = GPL2
diff --git a/PKGBUILD b/PKGBUILD
index 2dd446411db4..31ce5d2f3d8e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=trakt-scrobbler
pkgver=1.0.0b6
-pkgrel=0
+pkgrel=1
pkgdesc="Automatically scrobble TV show episodes and movies you are watching to Trakt.tv! It keeps a history of everything you've watched!"
arch=(any)
@@ -20,6 +20,10 @@ build() {
python setup.py build
go-md2man -in "$srcdir/trakts-man.md" 2>/dev/null|gzip -n > trakts.1.gz
}
+pkgver()
+{
+ curl -s https://pypi.org/pypi/$pkgname/json|jq -r '.info.version'
+}
package()
{
cd "$srcdir/$pkgname-$pkgver"