summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMubashshir2020-04-20 14:27:53 +0600
committerMubashshir2020-04-20 14:28:35 +0600
commitbaab897c972c85bcb086d2a06db510db296e838f (patch)
tree08ffddb73d6c1600d551ea5a21daf16e380bdc28
parentdfb6421c92ad0d88f6724e8447b550dff3a05578 (diff)
downloadaur-baab897c972c85bcb086d2a06db510db296e838f.tar.gz
Updated manpage and dependencies.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--trakts-man.md57
3 files changed, 42 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index def3fc49fa4f..2eb0bac7da2b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = trakt-scrobbler
pkgdesc = Automatically scrobble TV show episodes and movies you are watching to Trakt.tv! It keeps a history of everything you've watched!
pkgver = 1.0.0b4
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/iamkroot/trakt-scrobbler
arch = any
license = GPL2
@@ -26,10 +26,12 @@ pkgbase = trakt-scrobbler
depends = python-cleo<0.8.0
depends = python-confuse>=1.1.0
depends = python-confuse<2.0.0
+ depends = systemd
+ optdepends = libnotify: Provides Desktop Notifications.
source = https://files.pythonhosted.org/packages/source/t/trakt-scrobbler/trakt-scrobbler-1.0.0b4.tar.gz
source = trakts-man.md
sha256sums = 1c450bf8b6f183a7ddf8bad1540e32969cce8518bf84b9fe16a2456f260ef116
- sha256sums = cac6796e584a717a7a9e48c308647ec14d3aad883a9d7411bc7b4132995416e1
+ sha256sums = 81c3fb93bf01c0e6c0bbc9b2ef853da3f691bc3c50b4a87a68072b11ba72691c
pkgname = trakt-scrobbler
diff --git a/PKGBUILD b/PKGBUILD
index ea8f8465bc21..95d5c817a4ec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=trakt-scrobbler
pkgver=1.0.0b4
-pkgrel=2
+pkgrel=3
pkgdesc="Automatically scrobble TV show episodes and movies you are watching to Trakt.tv! It keeps a history of everything you've watched!"
arch=(any)
@@ -10,13 +10,15 @@ url=https://github.com/iamkroot/trakt-scrobbler
license=(GPL2)
depends=(
$(curl -s https://pypi.org/pypi/trakt-scrobbler/$pkgver/json|jq -r '.info|.requires_python, .requires_dist[]'|grep -v win32|sed -E 's/^>=([[:digit:].-]+),<([[:digit:].-]+)$/python>=\1\npython<\2/;s/^([[:alnum:]]+) \(>=([[:alnum:].-]+),<([[:alnum:].-]+)\)$/python-\1>=\2\npython-\1<\3/')
+ 'systemd'
)
+optdepends=('libnotify: Provides Desktop Notifications.')
makedepends=(python-setuptools jq curl grep sed go-md2man gzip)
source=(https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz
trakts-man.md)
sha256sums=(
1c450bf8b6f183a7ddf8bad1540e32969cce8518bf84b9fe16a2456f260ef116
- cac6796e584a717a7a9e48c308647ec14d3aad883a9d7411bc7b4132995416e1
+ 81c3fb93bf01c0e6c0bbc9b2ef853da3f691bc3c50b4a87a68072b11ba72691c
)
build() {
cd "$srcdir/$pkgname-$pkgver"
diff --git a/trakts-man.md b/trakts-man.md
index 07cd6ad768d2..1bfcebb87735 100644
--- a/trakts-man.md
+++ b/trakts-man.md
@@ -77,48 +77,59 @@ Trakt.tv has a lot of [plugins](https://trakt.tv/apps) to automatically scrobble
`auth` [-f]
: `-f` Force run the flow, ignoring already existing credentials
-`autostart` [enable|disable]
+`autostart` \<enable|disable>
`enable` Installs and enables the autostart service
`disable` Disables the autostart service
-`backlog` [list|clear]
- `clear` Try to sync the backlog with trakt servers
- `list` List the files in backlog
+`backlog` \<list|clear>
+ `clear` Try to sync the backlog with trakt servers
+ `list` List the files in backlog
`config` list [--all]
- `list` Lists configuration settings. By default, only overriden values are shown
+ `list` Lists configuration settings. By default,
+ only overriden values are shown
`--all` Include default values too
`config` set [--add] \<key> \<value1> ... [<valueN>]
- `set` Set the value for a config parameter.
- Separate multiple values with spaces.
- For values containing space(s), surround them with double-quotes
-
- <key> Config parameter
- <value> Setting value
- --add In case of list values, add them to the end
+ `set` Set the value for a config parameter.
+ Separate multiple values with spaces.
+ For values containing space(s),
+ surround them with double-quotes
+
+ <key> Config parameter
+ <value> Setting value
+ --add In case of list values, add them to the end
instead of overwriting
- Eg:
- $ trakts config set players.monitored mpv vlc mpc-be
- will set: players.monitored = ['mpv', 'vlc' ]
- $ trakts config set --add players.monitored plex mpc-hc
- will add: players.monitored = ['mpv', 'vlc', 'plex', 'mpc-hc]
+ Eg:
+ $ trakts config set players.monitored mpv vlc mpc-be
+ will set: players.monitored = ['mpv', 'vlc' ]
+ $ trakts config set --add players.monitored plex mpc-hc
+ will add: players.monitored = ['mpv', 'vlc', 'plex', 'mpc-hc]
+
`config` unset \<key>
- `unset` Reset a config value to its default
- \<key> Config parameter
+ `unset` Reset a config value to its default
+ \<key> Config parameter
`help` [\<command1>] ... [\<commandN>]
-: \<command> The command name
+ \<command> The command name
-`log` [path|open]
- `open` Open the latest log file in your default editor
- `path` Prints the location of the log file
+`log` \<path|open>
+ `open` Open the latest log file in your default editor
+ `path` Prints the location of the log file
`plex` [-f]
: `-f` Force run the flow, ignoring already existing credentials
`start` [-r]
: -r Restart the service
+
+`whitelist` add \<folder1> ... [\<folderN>]
+ \<folder> Folder to be whitelisted
+
+`whitelist` \<remove|show>
+ `show` Show the current whitelist
+ `remove` Remove folder(s) from whitelist (interactive)
+
# AUTHORS
This program is written by Krut Patel(@iamkroot:github.com).