summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMubashshir2020-04-20 13:09:37 +0600
committerMubashshir2020-04-20 13:09:37 +0600
commitdfb6421c92ad0d88f6724e8447b550dff3a05578 (patch)
tree729b0b322041a409f18a2fc676a0d739f7c6c310
parenta9028bbf1fa178ffde5c24fc6c4d313a7a0f676a (diff)
downloadaur-dfb6421c92ad0d88f6724e8447b550dff3a05578.tar.gz
Added manpage for trakts command.
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD14
-rw-r--r--trakts-man.md129
4 files changed, 145 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 93c82c71ccc1..def3fc49fa4f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = trakt-scrobbler
pkgdesc = Automatically scrobble TV show episodes and movies you are watching to Trakt.tv! It keeps a history of everything you've watched!
pkgver = 1.0.0b4
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/iamkroot/trakt-scrobbler
arch = any
license = GPL2
@@ -10,6 +10,8 @@ pkgbase = trakt-scrobbler
makedepends = curl
makedepends = grep
makedepends = sed
+ makedepends = go-md2man
+ makedepends = gzip
depends = python>=3.7
depends = python<4.0
depends = python-requests>=2.22.0
@@ -25,7 +27,9 @@ pkgbase = trakt-scrobbler
depends = python-confuse>=1.1.0
depends = python-confuse<2.0.0
source = https://files.pythonhosted.org/packages/source/t/trakt-scrobbler/trakt-scrobbler-1.0.0b4.tar.gz
+ source = trakts-man.md
sha256sums = 1c450bf8b6f183a7ddf8bad1540e32969cce8518bf84b9fe16a2456f260ef116
+ sha256sums = cac6796e584a717a7a9e48c308647ec14d3aad883a9d7411bc7b4132995416e1
pkgname = trakt-scrobbler
diff --git a/.gitignore b/.gitignore
index f71c635dafda..95f47752dc06 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
*
!.gitignore
+!trakts-man.md
!PKGBUILD
!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index 39ce15d49005..ea8f8465bc21 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=trakt-scrobbler
pkgver=1.0.0b4
-pkgrel=1
+pkgrel=2
pkgdesc="Automatically scrobble TV show episodes and movies you are watching to Trakt.tv! It keeps a history of everything you've watched!"
arch=(any)
@@ -11,15 +11,21 @@ license=(GPL2)
depends=(
$(curl -s https://pypi.org/pypi/trakt-scrobbler/$pkgver/json|jq -r '.info|.requires_python, .requires_dist[]'|grep -v win32|sed -E 's/^>=([[:digit:].-]+),<([[:digit:].-]+)$/python>=\1\npython<\2/;s/^([[:alnum:]]+) \(>=([[:alnum:].-]+),<([[:alnum:].-]+)\)$/python-\1>=\2\npython-\1<\3/')
)
-makedepends=(python-setuptools jq curl grep sed)
-source=(https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz)
-sha256sums=(1c450bf8b6f183a7ddf8bad1540e32969cce8518bf84b9fe16a2456f260ef116)
+makedepends=(python-setuptools jq curl grep sed go-md2man gzip)
+source=(https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz
+ trakts-man.md)
+sha256sums=(
+ 1c450bf8b6f183a7ddf8bad1540e32969cce8518bf84b9fe16a2456f260ef116
+ cac6796e584a717a7a9e48c308647ec14d3aad883a9d7411bc7b4132995416e1
+)
build() {
cd "$srcdir/$pkgname-$pkgver"
python setup.py build
+ go-md2man -in "$srcdir/trakts-man.md"|gzip -n > trakts.1.gz
}
package()
{
cd "$srcdir/$pkgname-$pkgver"
python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm644 "trakts.1.gz" "$pkgdir/usr/share/man/man1/trakts.1.gz"
}
diff --git a/trakts-man.md b/trakts-man.md
new file mode 100644
index 000000000000..07cd6ad768d2
--- /dev/null
+++ b/trakts-man.md
@@ -0,0 +1,129 @@
+% TRAKTS(1) trakt-scrobbler User Manual
+# NAME
+
+trakts - a trakt.tv scrobbler for vlc, plex, mpv, mpc-be/mpc-hc.
+
+# SYNOPSIS
+
+ `trakts` [*OPTION...*] \<command> [args]
+
+# DESCRIPTION
+
+Trakt.tv has a lot of [plugins](https://trakt.tv/apps) to automatically scrobble the movies and episodes you watch from your media center. But there is a dearth of up-to-date apps for syncing your progress on Desktop environments. This is where `trakt-scrobbler` comes in! It is a Python application that runs in the background and monitors your media players for any new activity. When it detects some file being played, it determines the media info (such as name of the movie/show, episode number, etc.) and sends this to trakt servers, so that it can be marked as "Currently Watching" on your profile. No manual intervention required!
+
+# COMMANDS
+`auth`
+: Runs the authetication flow for trakt.tv
+
+`autostart`
+: Controls the autostart behaviour of the scrobbler
+
+`backlog`
+: Manage the backlog of watched media that haven't been synced with trakt servers yet
+
+`config`
+: Edits the scrobbler config settings
+
+`help`
+: Display the manual of a command
+
+`init`
+: Runs the initial setup of the scrobbler
+
+`log`
+: Access the log file, mainly for debugging purposes
+
+`plex`
+: Runs the authetication flow for plex media server.
+
+`run`
+: Run the scrobbler in the foreground
+
+`start`
+: Starts the trakt-scrobbler service. If already running, does nothing
+
+`status`
+: Shows the status trakt-scrobbler service
+
+
+`stop`
+: Stops the trakt-scrobbler service
+
+`whitelist`
+: Adds the given folder(s) to whitelist
+
+# GLOBAL OPTIONS
+
+`-h`, `--help`
+: Display this help message
+
+`-q`, `--quiet`
+: Do not output any message
+
+`-v`, `--verbose`
+: Increase the verbosity of messages: "-v" for normal output,"-vv" for more verbose output and "-vvv" for debug
+
+`-V`, `--version`
+: Display this application version
+
+`--ansi`, `--no-ansi`
+: Force/Disable ANSI output
+
+`-n`, `--no-interaction`
+: Do not ask any interactive question
+
+# COMMANDS SECTION
+
+`auth` [-f]
+: `-f` Force run the flow, ignoring already existing credentials
+
+`autostart` [enable|disable]
+ `enable` Installs and enables the autostart service
+ `disable` Disables the autostart service
+
+`backlog` [list|clear]
+ `clear` Try to sync the backlog with trakt servers
+ `list` List the files in backlog
+
+`config` list [--all]
+ `list` Lists configuration settings. By default, only overriden values are shown
+ `--all` Include default values too
+
+`config` set [--add] \<key> \<value1> ... [<valueN>]
+ `set` Set the value for a config parameter.
+ Separate multiple values with spaces.
+ For values containing space(s), surround them with double-quotes
+
+ <key> Config parameter
+ <value> Setting value
+ --add In case of list values, add them to the end
+ instead of overwriting
+ Eg:
+ $ trakts config set players.monitored mpv vlc mpc-be
+ will set: players.monitored = ['mpv', 'vlc' ]
+ $ trakts config set --add players.monitored plex mpc-hc
+ will add: players.monitored = ['mpv', 'vlc', 'plex', 'mpc-hc]
+`config` unset \<key>
+ `unset` Reset a config value to its default
+ \<key> Config parameter
+
+`help` [\<command1>] ... [\<commandN>]
+: \<command> The command name
+
+`log` [path|open]
+ `open` Open the latest log file in your default editor
+ `path` Prints the location of the log file
+
+`plex` [-f]
+: `-f` Force run the flow, ignoring already existing credentials
+
+`start` [-r]
+: -r Restart the service
+# AUTHORS
+
+This program is written by Krut Patel(@iamkroot:github.com).
+
+This manpage is written by Mubashshir(@ahmubashshir:github.com).
+
+# REPORTING BUGS
+Report bugs and issues to [github](https://github.com/iamkroot/trakt-scrobbler/issues).