summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorClaudia Pellegrino2022-07-11 08:57:48 +0200
committerClaudia Pellegrino2022-07-11 08:57:48 +0200
commit2d61cf9dd3371d08ea1260d0665199710d06c455 (patch)
tree8d5dd4a120ec2be99ceaa3c8b466e5831f15ec73
downloadaur-2d61cf9dd3371d08ea1260d0665199710d06c455.tar.gz
trane v0.2.2
-rw-r--r--.SRCINFO13
-rw-r--r--.editorconfig20
-rw-r--r--.gitignore8
-rw-r--r--.shellcheckrc9
-rw-r--r--PKGBUILD47
5 files changed, 97 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..196064b99557
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = trane
+ pkgdesc = Automated system for learning complex skills
+ pkgver = 0.2.2
+ pkgrel = 1
+ url = https://github.com/trane-project/trane-cli
+ arch = x86_64
+ license = GPL3
+ makedepends = cargo
+ conflicts = trane-git
+ source = trane-0.2.2.tar.gz::https://github.com/trane-project/trane-cli/archive/v0.2.2.tar.gz
+ sha512sums = 85af830c2b2ad03102a589bac127c754d690883feb3debac7f59006fac4f50a7b6786d848a896d17d4212bb7442ae9a88d4fbf5618c4e447b0c60958a72e8ee3
+
+pkgname = trane
diff --git a/.editorconfig b/.editorconfig
new file mode 100644
index 000000000000..29215c86a3df
--- /dev/null
+++ b/.editorconfig
@@ -0,0 +1,20 @@
+# https://editorconfig.org
+
+root = true
+
+[*]
+charset = utf-8
+end_of_line = lf
+indent_style = space
+insert_final_newline = true
+trim_trailing_whitespace = true
+
+[*.{diff,patch}]
+end_of_line = lf
+trim_trailing_whitespace = false
+
+[PKGBUILD]
+indent_size = 2
+
+[*.json]
+indent_size = 2
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..59e5a76cb777
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+/.vscode/
+/src
+/pkg
+.trane_history
+*.log
+*.pkg.*
+*.tar.*
+*.zip
diff --git a/.shellcheckrc b/.shellcheckrc
new file mode 100644
index 000000000000..0c7908316b8f
--- /dev/null
+++ b/.shellcheckrc
@@ -0,0 +1,9 @@
+shell=bash
+
+# Allow implicitly exported variables, e.g. pkgrel
+# See also: https://github.com/koalaman/shellcheck/issues/2356
+disable=SC2034
+
+# Allow implicitly sourced variables, e.g. pkgdir
+# See also: https://github.com/koalaman/shellcheck/issues/356
+disable=SC2154
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cd6ea08e3b56
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Claudia Pellegrino <aur ät cpellegrino.de>
+
+_upstream_pkgname=trane-cli
+pkgname=trane
+pkgver=0.2.2
+pkgrel=1
+pkgdesc='Automated system for learning complex skills'
+arch=('x86_64')
+url='https://github.com/trane-project/trane-cli'
+license=('GPL3')
+makedepends=('cargo')
+conflicts=('trane-git')
+
+source=(
+ "${pkgname}-${pkgver}.tar.gz::https://github.com/trane-project/trane-cli/archive/v${pkgver}.tar.gz"
+)
+
+sha512sums=(
+ '85af830c2b2ad03102a589bac127c754d690883feb3debac7f59006fac4f50a7b6786d848a896d17d4212bb7442ae9a88d4fbf5618c4e447b0c60958a72e8ee3'
+)
+
+prepare() {
+ cargo fetch \
+ --manifest-path "${_upstream_pkgname}-${pkgver}/Cargo.toml" \
+ --target "${CARCH}-unknown-linux-gnu"
+}
+
+build() {
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --frozen --release --all-features \
+ --manifest-path "${_upstream_pkgname}-${pkgver}/Cargo.toml"
+}
+
+package() {
+ echo >&2 'Packaging the license'
+ install -D -m 644 -t "${pkgdir}/usr/share/licenses/${pkgname}" \
+ "${_upstream_pkgname}-${pkgver}/LICENSE"
+
+ echo >&2 'Packaging the documentation'
+ install -D -m 644 -t "${pkgdir}/usr/share/doc/${pkgname}" \
+ "${_upstream_pkgname}-${pkgver}/README.md"
+
+ echo >&2 'Packaging the executable'
+ install -D -m 755 -t "${pkgdir}/usr/bin/" \
+ "${srcdir}/${CARGO_TARGET_DIR}/release/${pkgname}"
+}