summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHarvettFox962021-09-26 09:47:23 +0800
committerHarvettFox962021-09-26 09:47:23 +0800
commit0978f337121af880cf7fbe6c3d77e9d4d9056538 (patch)
treed2bcd17db17a905865a0b2bcb8cea7776eb966ff
downloadaur-0978f337121af880cf7fbe6c3d77e9d4d9056538.tar.gz
Initial commit.
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD77
-rw-r--r--app-transcend-128px.pngbin0 -> 15552 bytes
3 files changed, 101 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2d8274070cdd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = transcend
+ pkgdesc = retro-style, abstract 2D shooter
+ pkgver = 0.3
+ pkgrel = 1
+ url = http://transcend.sourceforge.net/
+ arch = x86_64
+ arch = i686
+ groups = games
+ license = GPL-2
+ makedepends = graphicsmagick
+ makedepends = quilt
+ depends = freeglut
+ depends = glu
+ depends = portaudio
+ depends = mesa-libgl
+ source = transcend-0.3.tar.gz::https://downloads.sourceforge.net/transcend/Transcend_0.3_UnixSource.tar.gz
+ source = https://deb.debian.org/debian/pool/main/t/transcend/transcend_0.3.dfsg2-3.debian.tar.gz
+ source = app-transcend-128px.png
+ sha512sums = 5a2d21256c202ee045f8e2c926705f79885f6efbb5f44d3129e5b05cb1e28f909a32a5d873a9673d5fa48cbe4e79766c44947f147089e988e2fa3f83cde1b91d
+ sha512sums = 572c411d3c1f83f14f67e31201846d4b9bec3561f166cf03e327c730e557ce66f3b84ea20a2ed3e731b0d688209ba3ce6ee1a0846a23f5607001be9364dcba20
+ sha512sums = 1f94578424efaa06e4121674ee75103de56507402b31fc51a7a9784fd380ca320404029b27ad976c1019f38b4c08b2557627a457fd1663b32542e20009f2f00e
+
+pkgname = transcend
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6418e90e2230
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,77 @@
+# Maintainer: Jayvee Enaguas <harvettfox96@dismail.de>
+
+pkgname=transcend
+pkgver=0.3
+pkgrel=1
+_debver=0.3
+_dfsgrel=dfsg2
+_debrel=3
+pkgdesc="retro-style, abstract 2D shooter"
+arch=('x86_64' 'i686')
+url="http://transcend.sourceforge.net/"
+license=('GPL-2')
+depends=('freeglut' 'glu' 'portaudio' 'mesa-libgl')
+makedepends=('graphicsmagick' 'quilt')
+groups=('games')
+source=("${pkgname}-${pkgver}.tar.gz::https://downloads.sourceforge.net/${pkgname}/${pkgname^}_${pkgver}_UnixSource.tar.gz"
+ "https://deb.debian.org/debian/pool/main/t/${pkgname}/${pkgname}_${_debver}.${_dfsgrel}-${_debrel}.debian.tar.gz"
+ "app-transcend-128px.png")
+sha512sums=('5a2d21256c202ee045f8e2c926705f79885f6efbb5f44d3129e5b05cb1e28f909a32a5d873a9673d5fa48cbe4e79766c44947f147089e988e2fa3f83cde1b91d'
+ '572c411d3c1f83f14f67e31201846d4b9bec3561f166cf03e327c730e557ce66f3b84ea20a2ed3e731b0d688209ba3ce6ee1a0846a23f5607001be9364dcba20'
+ '1f94578424efaa06e4121674ee75103de56507402b31fc51a7a9784fd380ca320404029b27ad976c1019f38b4c08b2557627a457fd1663b32542e20009f2f00e')
+
+prepare() {
+ mv -v ${pkgname^}_${pkgver}_UnixSource ${pkgname}-${pkgver} && cd ${pkgname}-${pkgver}
+
+ if [[ ${pkgver%.*} = ${_debver%.*} ]]; then
+ # Debian patches
+ export QUILT_PATCHES=debian/patches
+ export QUILT_REFRESH_ARGS="-p ab --no-timestamps --no-index"
+ export QUILT_DIFF_ARGS="--no-timestamps"
+
+ cp -rv ${srcdir}/debian .
+
+ quilt push -av
+ fi
+
+ # Remove non-free and unused directories and files.
+ rm -frv ${pkgname^}/portaudio
+ rm -frv minorGems/util/development/fortify
+ rm -v minorGems/graphics/openGL/{texture,tga}.*
+ # Increase window size to 640x480 from the original.
+ sed -i 's#300, 300#640, 480#' ${pkgname^}/game/game.cpp
+ # Resize icon size to 32px square and convert to XPM.
+ gm convert -verbose -scale 32x32 ../app-${pkgname}-{128,32}px.png
+ gm convert -verbose ../app-${pkgname}-32px.{png,xpm}
+ # Generate a make file preparing to build.
+ cd ${pkgname^} && platformSelection=1 ./configure
+}
+
+build() {
+ cd ${pkgname}-${pkgver}
+
+ make OPTIMIZE_FLAG="$(CPPFLAGS) $(CXXFLAGS) -DLEVELS_DIR=\\\"/usr/share/games/${pkgname}/levels\\\"" PLATFORM_LINK_FLAGS="$(LDFLAGS) -lGL -lGLU -lglut -lportaudio -lpthread" VERBOSE=1 -C ${pkgname^}/game
+ # Compress manual file into gzip.
+ gzip -v9 debian/${pkgname^}.6
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+
+ # Install levels directory.
+ install -dv ${pkgdir}/usr/share/games/${pkgname} && cp -rv ${pkgname^}/levels ${pkgdir}/usr/share/games/${pkgname}
+ # Install binary, app shortcut and icon, manual, and licence files.
+ install -Dvm755 ${pkgname^}/game/${pkgname^} ${pkgdir}/usr/games/${pkgname}
+ ln -fs ${pkgdir}/usr/games/{${pkgname},${pkgname^}}
+ install -Dvm644 debian/${pkgname}.desktop -t ${pkgdir}/usr/share/applications
+ install -Dvm644 debian/menu ${pkgdir}/usr/share/menu/${pkgname}
+ for res in {32,128}; do
+ install -Dvm644 ../app-${pkgname}-${res}px.png -t ${pkgdir}/usr/share/icons/hicolor/${res}x${res}/apps/${pkgname}.png
+ done
+ for ext in {png,xpm}; do
+ install -Dvm644 ../app-${pkgname}-32px.${ext} ${pkgdir}/usr/share/pixmaps/${pkgname}.${ext}
+ done
+ install -Dvm644 debian/${pkgname^}.6.gz ${pkgdir}/usr/share/man/man6/${pkgname}.6.gz
+ ln -fs ${pkgdir}/usr/share/man/man6/{${pkgname},${pkgname^}}.6.gz
+ install -Dvm644 debian/copyright ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}
diff --git a/app-transcend-128px.png b/app-transcend-128px.png
new file mode 100644
index 000000000000..73960ff3811f
--- /dev/null
+++ b/app-transcend-128px.png
Binary files differ