summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKonstantin Shalygin2019-05-01 22:06:20 +0700
committerKonstantin Shalygin2019-05-01 22:06:20 +0700
commit313d053d3a12ddf300723a66c7040aaee97b5df9 (patch)
tree891c0c7b47509657a8df9201f50ad6c147cd4363
parentc8864795150e86ee9f650630c0bfaf06aab3d3b5 (diff)
downloadaur-313d053d3a12ddf300723a66c7040aaee97b5df9.tar.gz
Use QT5 for qt build (support HiDPI)
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d978f99adabb..669fdd9f25f3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Mon Dec 31 03:48:54 UTC 2018
+# Wed May 1 15:05:43 UTC 2019
pkgbase = transgui
pkgdesc = A feature rich cross platform Transmission BitTorrent client. Faster and has more functionality than the built-in web GUI.
pkgver = 5.16.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/transmission-remote-gui/transgui
arch = i686
arch = x86_64
@@ -17,7 +17,7 @@ pkgbase = transgui
sha256sums = 6c1723e084bd4afc908957e005dea60f919b42426d82cbcdee89239c64c6093d
pkgname = transgui-qt
- depends = qt4pas
+ depends = qt5pas
conflicts = transgui-gtk2-git
conflicts = transgui-qt4-git
conflicts = transmission-remote-gui-qt4
@@ -26,7 +26,7 @@ pkgname = transgui-qt
conflicts = transgui-gtk
pkgname = transgui-gtk
- depends = gtk2
+ depends = gtk
conflicts = transgui-gtk2-git
conflicts = transgui-qt4-git
conflicts = transmission-remote-gui-qt4
diff --git a/PKGBUILD b/PKGBUILD
index b141d3d97baa..07e0f382bdc5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgbase='transgui'
pkgname=("${pkgbase}-qt" "${pkgbase}-gtk")
pkgver='5.16.0'
-pkgrel='2'
+pkgrel='3'
pkgdesc='A feature rich cross platform Transmission BitTorrent client. Faster and has more functionality than the built-in web GUI.'
arch=('i686' 'x86_64')
url="https://github.com/transmission-remote-gui/${pkgbase}"
@@ -23,7 +23,7 @@ prepare() {
}
package_transgui-qt() {
- depends=('qt4pas')
+ depends=('qt5pas')
conflicts=('transgui-gtk2-git' 'transgui-qt4-git' 'transmission-remote-gui-qt4'
'transmission-remote-gui-gtk2' 'transmission-remote-gui-bin' 'transgui-gtk')
@@ -32,7 +32,7 @@ package_transgui-qt() {
lazbuild "${pkgbase}.lpi" \
--lazarusdir="/usr/lib/lazarus" \
- --widgetset="qt" \
+ --widgetset="qt5" \
--primary-config-path=../build-qt
install -Dm755 "units/${pkgbase}" "${pkgdir}/usr/bin/${pkgbase}"
@@ -47,7 +47,7 @@ package_transgui-qt() {
}
package_transgui-gtk() {
- depends=('gtk2')
+ depends=('gtk')
conflicts=('transgui-gtk2-git' 'transgui-qt4-git' 'transmission-remote-gui-qt4'
'transmission-remote-gui-gtk2' 'transmission-remote-gui-bin' 'transgui-qt')
@@ -56,7 +56,7 @@ package_transgui-gtk() {
lazbuild "${pkgbase}.lpi" \
--lazarusdir="/usr/lib/lazarus" \
- --widgetset="gtk2" \
+ --widgetset="gtk3" \
--primary-config-path=../build-gtk
install -Dm755 "units/${pkgbase}" "${pkgdir}/usr/bin/${pkgbase}"