summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander2016-01-08 18:40:32 +0500
committerAlexander2016-01-08 18:40:32 +0500
commit84b352a6a61a092b826d64e7cdfc63472f8b1998 (patch)
tree552fb092f9e1ef24dc7311d457eff99742b3bd06
downloadaur-84b352a6a61a092b826d64e7cdfc63472f8b1998.tar.gz
create package
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD39
-rw-r--r--transgui.desktop9
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b4dd583b4289
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Fri Jan 8 13:32:19 UTC 2016
+pkgbase = transgui
+ pkgdesc = A cross platform front-end for the Transmission Bit-Torrent client
+ pkgver = 5.0.1
+ pkgrel = 1
+ url = http://sourceforge.net/projects/transgui
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = lazarus>=1.0
+ source = http://sourceforge.net/projects/transgui/files/5.0.1/transgui-5.0.1-src.zip
+ source = transgui.desktop
+ md5sums = 471ed1f3f75a0ebcc9d3a0cb72f2a61c
+ md5sums = 1220f32805a5afa6b41cc1a3894ede65
+
+pkgname = transgui
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..49ce963a675a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Contributor: Alexander Mamzikov <av.mamzikov@gmail.com>
+
+pkgname=transgui
+pkgver=5.0.1
+pkgrel=1
+pkgdesc="A cross platform front-end for the Transmission Bit-Torrent client"
+arch=('i686' 'x86_64')
+url="http://sourceforge.net/projects/transgui"
+license=('GPL2')
+groups=()
+depends=()
+makedepends=('lazarus>=1.0')
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+source=(http://sourceforge.net/projects/${pkgname}/files/${pkgver}/${pkgname}-${pkgver}-src.zip
+ ${pkgname}.desktop)
+noextract=()
+md5sums=('471ed1f3f75a0ebcc9d3a0cb72f2a61c'
+ '1220f32805a5afa6b41cc1a3894ede65') #generate with 'makepkg -g'
+
+build() {
+ cd "$srcdir/TransGUI"
+ make
+}
+
+package()
+{
+ cd "${srcdir}/TransGUI"
+ install -D ${pkgname} "${pkgdir}/usr/bin/${pkgname}"
+ install -d lang "${pkgdir}/usr/share/${pkgname}/lang"
+ install -D -m644 lang/* "${pkgdir}/usr/share/${pkgname}/lang/"
+ install -D -m644 transgui.png "${pkgdir}/usr/share/icons/${pkgname}.png"
+ install -D -m644 ../${pkgname}.desktop "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+}
diff --git a/transgui.desktop b/transgui.desktop
new file mode 100644
index 000000000000..4c3feaee3bf3
--- /dev/null
+++ b/transgui.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Transmission Remote GUI
+Comment=A cross platform front-end for the Transmission Bit-Torrent client
+Comment[ru]=Кросс-платформенный удалённый интерфейс для Bit-Torrent клиента Transmission
+Exec=/usr/bin/transgui
+Icon=/usr/share/icons/transgui.png
+Terminal=false
+Type=Application
+Categories=Network