summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNikolay Bogoychev2022-06-04 16:44:50 +0100
committerNikolay Bogoychev2022-06-04 16:44:50 +0100
commit09b5050413cd1e8b3787ee031f61bc4002ed0f9b (patch)
tree9e188108b9319978ca188840a97ee59406e616ca
parent650730470f3829357f099557080f26f5a7a21f07 (diff)
downloadaur-09b5050413cd1e8b3787ee031f61bc4002ed0f9b.tar.gz
Build using clang as opposed to using gcc
gcc 12 coughs on intrusive pointer and not sure how to solve that, so until then force clang
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 64ca718c5764..3e4d5093f790 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,7 +8,7 @@ pkgbase = translatelocally-git
makedepends = git
makedepends = cmake
makedepends = qt5-tools
- makedepends = gcc-libs
+ makedepends = clang
makedepends = make
makedepends = binutils
makedepends = intel-mkl-static
diff --git a/PKGBUILD b/PKGBUILD
index a87584057d98..d49e30fc70da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ arch=('x86_64')
url='https://github.com/XapaJIaMnu/translateLocally'
license=('MIT')
depends=('qt5-base' 'qt5-svg' 'pcre2' 'libarchive' 'protobuf')
-makedepends=('git' 'cmake' 'qt5-tools' 'gcc-libs' 'make' 'binutils' 'intel-mkl-static')
+makedepends=('git' 'cmake' 'qt5-tools' 'clang' 'make' 'binutils' 'intel-mkl-static')
source=("git+$url.git")
sha256sums=('SKIP')
@@ -23,7 +23,7 @@ build() {
cd translateLocally
mkdir -p build
cd build
- cmake .. \
+ CC=clang CXX=clang++ cmake .. \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr
make