summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNikolay Bogoychev2021-05-03 16:33:31 +0100
committerNikolay Bogoychev2021-05-03 16:33:31 +0100
commitb6f685e5e1f0649b6feb0e5c164a8dc2fd7063f0 (patch)
tree0e6990785b9658ff60b956cbc51bf73cfcd2f4e1
downloadaur-b6f685e5e1f0649b6feb0e5c164a8dc2fd7063f0.tar.gz
Initial push
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD36
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fc12811bc2c0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = translatelocally-git
+ pkgdesc = A fast privacy focussed machine translation toolkit that translates on your own machine.
+ pkgver = 0.01
+ pkgrel = 1
+ url = https://github.com/XapaJIaMnu/translateLocally
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = cmake
+ makedepends = gcc-libs
+ makedepends = make
+ makedepends = binutils
+ depends = qt5-base
+ depends = qt5-tools
+ depends = libarchive
+ depends = protobuf
+ source = git+https://github.com/XapaJIaMnu/translateLocally.git
+ sha256sums = SKIP
+
+pkgname = translatelocally-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dfd415f92a01
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Nikolay Bogoychev <nheart@gmail.com>
+
+pkgname=translatelocally-git
+pkgver=0.01
+pkgrel=1
+pkgdesc='A fast privacy focussed machine translation toolkit that translates on your own machine.'
+arch=('x86_64')
+url='https://github.com/XapaJIaMnu/translateLocally'
+license=('MIT')
+depends=('qt5-base' 'qt5-tools' 'libarchive' 'protobuf')
+makedepends=('git' 'cmake' 'gcc-libs' 'make' 'binutils')
+source=("git+$url.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd translateLocally
+ # No tags, do this when we have tags
+ # git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git rev-parse --short HEAD
+}
+
+build() {
+ cd translateLocally
+ mkdir -p build
+ cd build
+ cmake .. -DSSPLIT_USE_INTERNAL_PCRE2=ON -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr
+ make #${MAKEFLAGS}
+ strip -s translateLocally
+}
+
+package() {
+ cd translateLocally
+ install -Dm644 LICENCE.md "$pkgdir/usr/share/licenses/$pkgname/LICENCE"
+ cd build
+ make DESTDIR="$pkgdir" install
+}