summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-06-04 19:54:50 +0800
committerzxp198210052023-06-04 19:54:50 +0800
commit117699b726442b0a4cd16179a9175ffe888a56a2 (patch)
treed16b7fe92ce32b313abfc2aee906128c379ba5b8
downloadaur-117699b726442b0a4cd16179a9175ffe888a56a2.tar.gz
first release
-rw-r--r--.SRCINFO39
-rw-r--r--PKGBUILD27
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8c5aab6c0d83
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,39 @@
+pkgbase = translationcore-bin
+ pkgdesc = An open source platform for checking and managing Bible translation projects
+ pkgver = 3.4.0lite
+ pkgrel = 1
+ url = https://www.translationcore.com/
+ arch = x86_64
+ license = ISC
+ depends = nss
+ depends = pango
+ depends = gdk-pixbuf2
+ depends = alsa-lib
+ depends = libxcb
+ depends = libxdamage
+ depends = glibc
+ depends = cairo
+ depends = nspr
+ depends = libcups
+ depends = libxfixes
+ depends = libxkbcommon
+ depends = at-spi2-core
+ depends = libxrandr
+ depends = expat
+ depends = hicolor-icon-theme
+ depends = gtk3
+ depends = glib2
+ depends = libdrm
+ depends = libxext
+ depends = dbus
+ depends = mesa
+ depends = gcc-libs
+ depends = libxcomposite
+ depends = libx11
+ conflicts = translationcore
+ source = translationcore-3.4.0lite.deb::https://github.com/unfoldingWord/translationCore/releases/download/v3.4.0-LITE/tC-linux-x64-3.4.0-LITE-5b601bd.deb
+ source = LICENSE::https://raw.githubusercontent.com/unfoldingWord/translationCore/develop/LICENSE
+ sha256sums = 171ce1a32db7b30464a3d4b9296a4cefa6f789f8c6873b7964f9058da1231434
+ sha256sums = a756bd73c46e3e9b85ff0222658f4c63851ebc5af63811adc4333ff618688417
+
+pkgname = translationcore-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c80f7617a064
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+pkgname="translationcore-bin"
+pkgver=3.4.0lite
+_pkgver=3.4.0-LITE
+pkgrel=1
+pkgdesc="An open source platform for checking and managing Bible translation projects"
+arch=('x86_64')
+url="https://www.translationcore.com/"
+_githuburl="https://github.com/unfoldingWord/translationCore"
+license=('ISC')
+conflicts=("${pkgname%-bin}")
+depends=('nss' 'pango' 'gdk-pixbuf2' 'alsa-lib' 'libxcb' 'libxdamage' 'glibc' 'cairo' 'nspr' 'libcups' 'libxfixes' 'libxkbcommon' 'at-spi2-core' \
+ 'libxrandr' 'expat' 'hicolor-icon-theme' 'gtk3' 'glib2' 'libdrm' 'libxext' 'dbus' 'mesa' 'gcc-libs' 'libxcomposite' 'libx11')
+source=("${pkgname%-bin}-${pkgver}.deb::${_githuburl}/releases/download/v${_pkgver}/tC-linux-x64-${_pkgver}-5b601bd.deb"
+ "LICENSE::https://raw.githubusercontent.com/unfoldingWord/translationCore/develop/LICENSE")
+sha256sums=('171ce1a32db7b30464a3d4b9296a4cefa6f789f8c6873b7964f9058da1231434'
+ 'a756bd73c46e3e9b85ff0222658f4c63851ebc5af63811adc4333ff618688417')
+
+package() {
+ bsdtar -xf "${srcdir}/data.tar.xz" -C "${pkgdir}"
+ sed "s|unfoldingword-${pkgname%-bin}|${pkgname%-bin}|g" -i "${pkgdir}/opt/${pkgname%-bin}/unfoldingword-${pkgname%-bin}.desktop"
+ install -Dm644 "${pkgdir}/opt/${pkgname%-bin}/unfoldingword-${pkgname%-bin}.desktop" "${pkgdir}/usr/share/applications/${pkgname%-bin}.desktop"
+ for _icons in 16 22 32 48 64 128;do
+ install -Dm644 "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}-${_icons}.png" "${pkgdir}/usr/share/icons/hicolor/${_icons}x${_icons}/apps/${pkgname%-bin}.png"
+ done
+ install -Dm644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+} \ No newline at end of file