summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-09-13 13:40:57 +0800
committerzxp198210052023-09-13 13:40:57 +0800
commit17570c608e121a02f185710e16ab1e06f2a05460 (patch)
tree7caafa34dcb5a2a1c18d794b69d422784a9f3bd1
parentfe0f15081ca18c81696cbd9f9468099e474430ec (diff)
downloadaur-17570c608e121a02f185710e16ab1e06f2a05460.tar.gz
fix errors
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD15
2 files changed, 12 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 084c7fb4fc6e..885d5eefcf04 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = translationcore-bin
pkgdesc = An open source platform for checking and managing Bible translation projects
pkgver = 3.5.1
- pkgrel = 1
+ pkgrel = 2
url = https://www.translationcore.com/
arch = aarch64
arch = x86_64
@@ -12,7 +12,7 @@ pkgbase = translationcore-bin
depends = hicolor-icon-theme
provides = translationcore=3.5.1
conflicts = translationcore
- source = LICENSE::https://raw.githubusercontent.com/unfoldingWord/translationCore/develop/LICENSE
+ source = LICENSE::https://raw.githubusercontent.com/unfoldingWord/translationCore/v3.5.1/LICENSE
source = translationcore.sh
sha256sums = a756bd73c46e3e9b85ff0222658f4c63851ebc5af63811adc4333ff618688417
sha256sums = eb05b462f6b48d3b3e51622881942cff873d8a809ce030df46d6eaec2c40c724
diff --git a/PKGBUILD b/PKGBUILD
index 6c3250ffd953..8c00acc88b98 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=translationcore-bin
+_pkgname=translationCore
pkgver=3.5.1
-pkgrel=1
+pkgrel=2
pkgdesc="An open source platform for checking and managing Bible translation projects"
arch=('aarch64' 'x86_64')
url="https://www.translationcore.com/"
@@ -13,17 +14,21 @@ depends=('bash' 'electron25' 'hicolor-icon-theme')
makedepends=('asar')
source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.deb::${_githuburl}/releases/download/v${pkgver}/tC-linux-arm64-${pkgver}-MAX-6e1cd7b.deb")
source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.deb::${_githuburl}/releases/download/v${pkgver}/tC-linux-x64-${pkgver}-MAX-6e1cd7b.deb")
-source=("LICENSE::https://raw.githubusercontent.com/unfoldingWord/translationCore/develop/LICENSE"
+source=("LICENSE::https://raw.githubusercontent.com/unfoldingWord/translationCore/v${pkgver}/LICENSE"
"${pkgname%-bin}.sh")
sha256sums=('a756bd73c46e3e9b85ff0222658f4c63851ebc5af63811adc4333ff618688417'
'eb05b462f6b48d3b3e51622881942cff873d8a809ce030df46d6eaec2c40c724')
sha256sums_aarch64=('6df8af5f0a5a8249a52944f41685765ac576521d561e910cb81162b4bca144ae')
sha256sums_x86_64=('6a5423c5b368a0538e9809d3ad625b12d245ed88766c17a3126751a36585ebd4')
-package() {
+prepare() {
bsdtar -xf "${srcdir}/data.tar.xz"
+ asar pack "${srcdir}/opt/${pkgname%-bin}/resources/app" "${srcdir}/${pkgname%-bin}.asar"
+ sed "s|/opt/${pkgname%-bin}/${_pkgname}|${pkgname%-bin}|g;s|unfoldingword-${pkgname%-bin}|${pkgname%-bin}|g" \
+ -i "${srcdir}/opt/${pkgname%-bin}/unfoldingword-${pkgname%-bin}.desktop"
+}
+package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}"
- asar pack "${srcdir}/opt/${pkgname%-bin}/resources/app" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}.asar"
- sed "s|unfoldingword-${pkgname%-bin}|${pkgname%-bin}|g" -i "${srcdir}/opt/${pkgname%-bin}/unfoldingword-${pkgname%-bin}.desktop"
+ install -Dm644 "${srcdir}/${pkgname%-bin}.asar" -t "${pkgdir}/opt/${pkgname%-bin}"
install -Dm644 "${srcdir}/opt/${pkgname%-bin}/unfoldingword-${pkgname%-bin}.desktop" "${pkgdir}/usr/share/applications/${pkgname%-bin}.desktop"
for _icons in 16 22 32 48 64 128;do
install -Dm644 "${srcdir}/opt/${pkgname%-bin}/${pkgname%-bin}-${_icons}.png" "${pkgdir}/usr/share/icons/hicolor/${_icons}x${_icons}/apps/${pkgname%-bin}.png"