summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorglitsj162023-07-09 16:46:29 +0200
committerglitsj162023-07-09 16:46:29 +0200
commit101b1481cef819c3cd240f4102a3c344ba468876 (patch)
treeb828a6bccf7b2f6f4632dc32ec55fd5171237fda
parent105a64d4b5fd28199549591543c1f7f594b06457 (diff)
downloadaur-101b1481cef819c3cd240f4102a3c344ba468876.tar.gz
follow package guidelines for git submodules
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
2 files changed, 13 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bacf7a4eec8f..fbb5d7aa71c2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = transmission-cli-git
- pkgdesc = Fast, easy, and free BitTorrent client (CLI tools and daemon and web client) - git version
+ pkgdesc = Fast, easy, and free BitTorrent client (CLI tools and daemon and web client)
pkgver = 4.0.3.r160.g8169d524e
- pkgrel = 2
+ pkgrel = 3
url = https://www.transmissionbt.com/
arch = x86_64
arch = armv7h
diff --git a/PKGBUILD b/PKGBUILD
index 7e43d68e137e..b3f7225e4c13 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,11 +7,11 @@ _pkgbase=transmission
_pkgname=transmission-cli
pkgname=transmission-cli-git
pkgver=4.0.3.r160.g8169d524e
-pkgrel=2
+pkgrel=3
arch=(x86_64 armv7h)
url="https://www.transmissionbt.com/"
license=(GPL)
-pkgdesc='Fast, easy, and free BitTorrent client (CLI tools and daemon and web client) - git version'
+pkgdesc='Fast, easy, and free BitTorrent client (CLI tools and daemon and web client)'
depends=(
curl
dht
@@ -46,7 +46,15 @@ pkgver() {
prepare() {
cd "$_pkgbase"
- git submodule update --init --recursive
+ git submodule init
+ git -c protocol.file.allow=always submodule update \
+ third-party/fast_float \
+ third-party/fmt \
+ third-party/googletest \
+ third-party/libutp \
+ third-party/small \
+ third-party/utfcpp \
+ third-party/wide-integer
}
build() {