summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMubashshir2023-03-24 21:57:54 +0600
committerMubashshir2023-03-24 22:02:33 +0600
commita770c168c3c914713177495119044c4bdd87ee8f (patch)
tree985b391b93e3a7beebb8da5dc044ab7e643b0120
downloadaur-a770c168c3c914713177495119044c4bdd87ee8f.tar.gz
Initial Release
Signed-off-by: Mubashshir <ahmubashshir@gmail.com>
-rw-r--r--.SRCINFO37
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD70
3 files changed, 110 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2e8cf32b5ff8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,37 @@
+pkgbase = transmission-gtk3
+ pkgdesc = Fast, easy, and free BitTorrent client (GTK+ GUI)
+ pkgver = 4.0.1
+ pkgrel = 1
+ url = http://www.transmissionbt.com/
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ makedepends = curl
+ makedepends = dht
+ makedepends = glibmm-2.68
+ makedepends = gtk3
+ makedepends = gtkmm3
+ makedepends = intltool
+ makedepends = libb64
+ makedepends = libdeflate
+ makedepends = libevent
+ makedepends = libnatpmp
+ makedepends = miniupnpc
+ makedepends = ninja
+ depends = curl
+ depends = libevent
+ depends = gtk3
+ depends = hicolor-icon-theme
+ depends = libb64
+ depends = miniupnpc
+ depends = libnatpmp
+ depends = libdeflate
+ depends = gtkmm3
+ optdepends = libnotify: Desktop notification support
+ optdepends = transmission-cli: daemon and web support
+ provides = transmission-gtk
+ conflicts = transmission-gtk
+ source = https://github.com/transmission/transmission/releases/download/4.0.1/transmission-4.0.1.tar.xz
+ sha256sums = 8fc5aef23638c983406f6a3ee9918369e4cdc84e3228bd2fb3d01dd55cdad900
+
+pkgname = transmission-gtk3
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1d65adf6de3a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5678c3140a98
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,70 @@
+# Maintainer : Mubashshir <ahmubashshir@gmail.com>
+# Contributor : Tom Gundersen <teg@jklm.no>
+# Contributor : Ionut Biru <ibiru@archlinux.org>
+# Contributor : Thomas Weißschuh <thomas t-8ch de>
+# Contributor : Florian Pritz <bluewind@xinu.at>
+# from: github
+# what: transmission/transmission
+# match! -beta\.?[0-9]+$
+
+pkgname=transmission-gtk3
+pkgver=4.0.1
+pkgrel=1
+arch=(x86_64)
+url="http://www.transmissionbt.com/"
+pkgdesc='Fast, easy, and free BitTorrent client (GTK+ GUI)'
+license=(GPL)
+provides=('transmission-gtk')
+conflicts=('transmission-gtk')
+depends=(curl libevent gtk3 hicolor-icon-theme libb64 miniupnpc libnatpmp libdeflate gtkmm3)
+optdepends=('libnotify: Desktop notification support'
+ 'transmission-cli: daemon and web support')
+
+makedepends=(
+ cmake
+ curl
+ dht
+ glibmm-2.68
+ gtk3
+ gtkmm3
+ intltool
+ libb64
+ libdeflate
+ libevent
+ libnatpmp
+ miniupnpc
+ ninja
+)
+source=("https://github.com/transmission/transmission/releases/download/$pkgver/transmission-$pkgver.tar.xz")
+sha256sums=('8fc5aef23638c983406f6a3ee9918369e4cdc84e3228bd2fb3d01dd55cdad900')
+
+build() {
+ export CFLAGS+=" -ffat-lto-objects -Wno-all"
+ cmake -G Ninja -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DENABLE_{CLI,DAEMON,MAC,QT,UTILS}=OFF \
+ -DINSTALL_{WEB,LIB}=OFF \
+ -DUSE_SYSTEM_UTP=OFF \
+ -DENABLE_{GTK,TESTS,UTP}=ON \
+ -DUSE_GTK_VERSION=3 \
+ -DUSE_SYSTEM_{B64,DEFLATE,DHT,EVENT2,MINIUPNPC,NATPMP,PSL}=ON \
+ -DWITH_CRYPTO=openssl \
+ -S "${pkgname%-gtk3}-$pkgver" -B build
+
+ cmake --build build --config Release
+}
+
+check() {
+ cd build
+ ctest --output-on-failure -j "$(nproc)"
+}
+
+package() {
+ for comp in gtk po
+ do DESTDIR="$pkgdir" ninja -C build "$comp/install"
+ done
+
+ install -Dm644 "${pkgname%-gtk3}-$pkgver/COPYING" "$pkgdir/usr/share/licenses/transmission-gtk/COPYING"
+}
+
+# vim: ft=sh:ts=2:et