summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorredfish2018-01-27 21:11:31 -0500
committerredfish2018-01-27 21:11:31 -0500
commit176c239f92c2182a4c9192fe374e0d459c84e54c (patch)
tree923a28143e144abe75a3333c4f820817b7484ce9
parent1bb40032fdd7e95ec2e63dd1dc206a6ad603991b (diff)
downloadaur-176c239f92c2182a4c9192fe374e0d459c84e54c.tar.gz
debug build
-rw-r--r--PKGBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b343f7151d86..a662ec88c002 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,6 +23,8 @@ md5sums=('SKIP'
'a5952b62a60d951948f9776aefa4715c')
install="transmission-i2p.install"
+#options=(debug)
+
pkgver() {
cd "$srcdir/$_gitname"
#echo $(git describe --tags --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g')
@@ -43,7 +45,12 @@ prepare() {
build() {
cd "$srcdir/$_gitname"
- CFLAGS="-D_LINUX_QUOTA_VERSION=2" \
+ if check_option "debug" "y"
+ then
+ DEBUG_CFLAGS="-D_DEBUG "
+ fi
+
+ CFLAGS="$DEBUG_CFLAGS -D_LINUX_QUOTA_VERSION=2 " \
LDFLAGS="-L/usr/lib/openssl-1.0" \
OPENSSL_CFLAGS="-I/usr/include/openssl-1.0" \
./configure --prefix=$pkgdir/usr \