summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDobroslaw Kijowski2016-03-10 17:38:19 +0100
committerDobroslaw Kijowski2016-03-10 17:38:19 +0100
commit4fae5d9ddfc17a49be7590c799fe897d09c326e2 (patch)
treee01714258de85b5002820c1c3e7a79a54e6a8041
parent8d6ec661658f8cbc04241e1983608d677d78bb61 (diff)
downloadaur-4fae5d9ddfc17a49be7590c799fe897d09c326e2.tar.gz
* Upgrade to 5.2.0.
* Add MimeTypes and Russian translation to .desktop. * Remove (hopefully) not needed patch.
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
-rw-r--r--fix_cannot_execte_on_open.patch58
-rw-r--r--transgui.desktop3
4 files changed, 20 insertions, 81 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 87473c69d643..9de6c4ca2b35 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,10 @@
+# Generated by mksrcinfo v8
+# Thu Mar 10 16:37:50 UTC 2016
pkgbase = transmission-remote-gui-gtk2
pkgdesc = Cross platform remote GUI for the Transmission daemon
- pkgver = 5.0.1
- pkgrel = 2
- url = http://code.google.com/p/transmisson-remote-gui/
+ pkgver = 5.2.0
+ pkgrel = 1
+ url = https://github.com/leonsoft-kras/transmisson-remote-gui
install = transmission-remote-gui.install
arch = i686
arch = x86_64
@@ -15,12 +17,10 @@ pkgbase = transmission-remote-gui-gtk2
conflicts = transmission-remote-gui-qt4
conflicts = transmission-remote-gui-svn
conflicts = transmission-remote-gui
- source = http://transmisson-remote-gui.googlecode.com/files/transgui-5.0.1-src.zip
+ source = https://github.com/leonsoft-kras/transmisson-remote-gui/archive/v5.2.0.zip
source = transgui.desktop
- source = fix_cannot_execte_on_open.patch
- md5sums = 471ed1f3f75a0ebcc9d3a0cb72f2a61c
- md5sums = cf55fd5a681d9b34a1f9c7d91b74d121
- md5sums = d2f40c9e7e7b86cdfa9c2e2135f18bd6
+ md5sums = c38ef3c65bbd2c0fe0828b8673707b2a
+ md5sums = c0504cb6d4e970892ac7be9206c787b5
pkgname = transmission-remote-gui-gtk2
diff --git a/PKGBUILD b/PKGBUILD
index 7b679e61b451..2d7b446e5299 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,37 +3,33 @@
pkgname=transmission-remote-gui-gtk2
_pkgname=transgui
-pkgver=5.0.1
-pkgrel=2
+pkgver=5.2.0
+pkgrel=1
pkgdesc='Cross platform remote GUI for the Transmission daemon'
arch=(i686 x86_64)
-url='http://code.google.com/p/transmisson-remote-gui/'
+url='https://github.com/leonsoft-kras/transmisson-remote-gui'
license=(GPL2)
depends=(gtk2 desktop-file-utils)
makedepends=(lazarus unzip)
provides=(transmission-remote-gui)
conflicts=(transmission-remote-gui-qt4 transmission-remote-gui-svn transmission-remote-gui)
install=transmission-remote-gui.install
-source=(http://transmisson-remote-gui.googlecode.com/files/${_pkgname}-${pkgver}-src.zip
- ${_pkgname}.desktop
- fix_cannot_execte_on_open.patch)
-md5sums=(471ed1f3f75a0ebcc9d3a0cb72f2a61c
- cf55fd5a681d9b34a1f9c7d91b74d121
- d2f40c9e7e7b86cdfa9c2e2135f18bd6)
+source=(https://github.com/leonsoft-kras/transmisson-remote-gui/archive/v${pkgver}.zip
+ ${_pkgname}.desktop)
+md5sums=(c38ef3c65bbd2c0fe0828b8673707b2a
+ c0504cb6d4e970892ac7be9206c787b5)
_ws=gtk2
build() {
mkdir ${srcdir}/config
- cd ${srcdir}/TransGUI
- # moonman's fix
- cp ${srcdir}/fix_cannot_execte_on_open.patch .
- patch -p1 < fix_cannot_execte_on_open.patch
+ cd ${srcdir}/transmisson-remote-gui-${pkgver}
+
lazbuild ${_pkgname}.lpi --lazarusdir=/usr/lib/lazarus --widgetset=${_ws} \
--primary-config-path=${srcdir}/config
}
package() {
- cd ${srcdir}/TransGUI
+ cd ${srcdir}/transmisson-remote-gui-${pkgver}
install -D -m 755 units/${_pkgname} ${pkgdir}/usr/bin/${_pkgname}
diff --git a/fix_cannot_execte_on_open.patch b/fix_cannot_execte_on_open.patch
deleted file mode 100644
index 40dd8d62599b..000000000000
--- a/fix_cannot_execte_on_open.patch
+++ /dev/null
@@ -1,58 +0,0 @@
-diff -ruN a/main.pas b/main.pas
---- a/main.pas 2014-01-04 03:51:46.000000000 -0700
-+++ b/main.pas 2014-04-09 04:02:16.811032289 -0600
-@@ -1005,10 +1005,9 @@
- // Restart the app with the LIBOVERLAY_SCROLLBAR=0 env var.
- proc:=TProcess.Create(nil);
- try
-- s:='';
-- for i:=0 to ParamCount do
-- s:=s + '"' + ParamStrUTF8(i) + '" ';
-- proc.CommandLine:=s;
-+ proc.Executable:=ParamStrUTF8(0);
-+ for i:=1 to ParamCount do
-+ proc.Parameters.Add(ParamStrUTF8(i));
- for i:=0 to GetEnvironmentVariableCount - 1 do
- proc.Environment.Add(GetEnvironmentString(i));
- proc.Environment.Values['LIBOVERLAY_SCROLLBAR']:='0';
-diff -ruN a/utils.pas b/utils.pas
---- a/utils.pas 2014-01-04 03:51:46.000000000 -0700
-+++ b/utils.pas 2014-04-09 04:05:21.552036348 -0600
-@@ -398,18 +398,21 @@
- cmd, fn: String;
- begin
- Result:=-1;
-+ WrkProcess:=TProcess.Create(nil);
-+ WrkProcess.Options:=[poNoConsole,poWaitOnExit];
-+
- cmd:=FindDefaultExecutablePath('xdg-open');
- if cmd = '' then begin
- cmd:=FindDefaultExecutablePath('gnome-open');
- if cmd = '' then begin
- cmd:=FindDefaultExecutablePath('kioclient');
- if cmd <> '' then
-- cmd:=cmd + ' exec'
-+ Wrkprocess.Parameters.Add('exec')
- else begin
- cmd:=FindDefaultExecutablePath('kfmclient');
- if cmd = '' then
- exit;
-- cmd:=cmd + ' exec';
-+ Wrkprocess.Parameters.Add('exec')
- end;
- end;
- end;
-@@ -417,11 +420,10 @@
- fn:=FileName;
- if Pos('://', fn) > 0 then
- fn:=StringReplace(fn, '#', '%23', [rfReplaceAll]);
-+ Wrkprocess.Parameters.Add(fn);
-+ WrkProcess.Executable:=cmd;
-
-- WrkProcess:=TProcess.Create(nil);
- try
-- WrkProcess.Options:=[poNoConsole];
-- WrkProcess.CommandLine:=cmd + ' "' + fn + '"';
- WrkProcess.Execute;
- Result:=WrkProcess.ExitStatus;
- finally
diff --git a/transgui.desktop b/transgui.desktop
index 5fa6a0775715..67ce29879c76 100644
--- a/transgui.desktop
+++ b/transgui.desktop
@@ -3,9 +3,10 @@ Encoding=UTF-8
Name=Transmission Remote GUI
GenericName=TransGUI
Comment=Cross platform remote GUI for the Transmission daemon
+Comment[ru]=Кроссплатформенный удалённый интерфейс для Bit-Torrent клиента Transmission
Exec=/usr/bin/transgui
Icon=/usr/share/pixmaps/transgui.png
Terminal=false
Type=Application
Categories=Network;FileTransfer;P2P;GTK;
-
+MimeType=application/x-bittorrent;application/x-torrent;x-scheme-handler/magnet;