summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Laroche2016-03-20 11:13:09 +0100
committerThomas Laroche2016-03-20 11:13:09 +0100
commitc35e6dd35f72ac4e1ab51d5838e03c31fc01cf88 (patch)
tree24c774ee1c7d19bce711aacf4053cb32b36c3e10
parent227d37db62b050ced98137f4bcd5ac0b0946f2e6 (diff)
downloadaur-c35e6dd35f72ac4e1ab51d5838e03c31fc01cf88.tar.gz
Fix for makepkg not providing --pkg option anymore
-rw-r--r--PKGBUILD14
1 files changed, 4 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1115775d610b..95a32f067e01 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,11 +19,8 @@ source=("https://github.com/Mikayex/transmission/archive/${pkgver}-seq.tar.gz" t
md5sums=('432fa500829c7890a9278966dd65cb2a'
'bcb54fdb9fec00992960d9bd3b449d4d')
-_inarray() {
- local e
- for e in "${@:2}"; do [[ "$e" == "$1" ]] && return 0; done
- return 1
-}
+BUILD_GTK=true
+BUILD_QT=true
prepare() {
cd transmission-$pkgver-seq
@@ -33,17 +30,14 @@ prepare() {
build() {
cd transmission-$pkgver-seq
-
-#Don't build if not needed since long to build
- if _inarray 'transmission-sequential-gtk' "${pkgname[@]}"; then
+ if [ "$BUILD_GTK" = true ] ; then
./autogen.sh --prefix=/usr
else
./autogen.sh --prefix=/usr --without-gtk
fi
make
-#Don't build if not needed since long to build
- if _inarray 'transmission-sequential-qt' "${pkgname[@]}"; then
+ if [ "$BUILD_QT" = true ] ; then
cd qt
qmake qtr.pro
make