summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn ShaggyTwoDope Jenkins2015-08-08 16:21:05 -0700
committerJohn ShaggyTwoDope Jenkins2015-08-08 16:21:05 -0700
commit2dea1c8a032a316ec14fb3c4641569758cb630a0 (patch)
treec155e856f80790391e75ae83843c5239af3b3e13
downloadaur-2dea1c8a032a316ec14fb3c4641569758cb630a0.tar.gz
init
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD33
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a67d29e332a0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = trash-cli-git
+ pkgdesc = Command line trashcan (recycle bin) interface
+ pkgver = 408.9078825
+ pkgrel = 2
+ url = http://github.com/andreafrancia/trash-cli
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = python2
+ depends = python2-distribute
+ provides = trash-cli
+ conflicts = trash-cli
+ source = git+http://github.com/andreafrancia/trash-cli.git
+ md5sums = SKIP
+
+pkgname = trash-cli-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..06abb6352284
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer : Johnathan Jenkins <twodopeshaggy@gmail.com>
+# Contributor: Trustin Lee <t@motd.kr>
+# Contributor: Renato Garcia <fgarcia.renato@gmail.com>
+pkgname=trash-cli-git
+_pkgname=trash-cli
+pkgver=413.7913a0b
+pkgrel=1
+pkgdesc='Command line trashcan (recycle bin) interface'
+arch=('any')
+url="http://github.com/andreafrancia/${_pkgname}"
+license=('GPL')
+depends=('python2' 'python2-distribute')
+makedepends=('git')
+provides=('trash-cli')
+conflicts=('trash-cli')
+source=("git+http://github.com/andreafrancia/${_pkgname}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ echo "$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${_pkgname}"
+ python2 setup.py build
+}
+
+package(){
+ cd "${_pkgname}"
+ python2 setup.py install --root="${pkgdir}"
+}
+