summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryo2019-05-14 00:04:15 +0200
committeryo2019-05-14 00:04:15 +0200
commit6dd7379bd6c296ee5c11fe090c9caa60233d5668 (patch)
treeeb353d6cefc57bb632c6d4c610ea09b7814e8d57
downloadaur-6dd7379bd6c296ee5c11fe090c9caa60233d5668.tar.gz
first commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD30
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7626a7e2e9d2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = trashf
+ pkgdesc = CLI tool to safely remove any file and directory by putting them in the trash
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://github.com/yoarch/trashf
+ arch = any
+ license = MIT
+ makedepends = python
+ makedepends = python-setuptools
+ depends = python>=3
+ source = https://files.pythonhosted.org/packages/source/t/trashf/trashf-1.0.1.tar.gz
+ sha256sums = d6026d56610963605e4c504fad254774fbbe0a3b3da68af421ba10326d4e9312
+
+pkgname = trashf
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c6a9b954b0ed
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..78b88d7550de
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Yann Orieult <yo.managements@gmail.com>
+
+pkgname=trashf
+pkgver='1.0.1'
+pkgrel='1'
+pkgdesc='CLI tool to safely remove any file and directory by putting them in the trash'
+arch=('any')
+url='https://github.com/yoarch/trashf'
+license=('MIT')
+depends=('python>=3')
+makedepends=('python' 'python-setuptools')
+
+source=("https://files.pythonhosted.org/packages/source/t/trashf/trashf-1.0.1.tar.gz")
+sha256sums=('d6026d56610963605e4c504fad254774fbbe0a3b3da68af421ba10326d4e9312')
+#source#=("file:///$MHOME/dev/python/trashf/dist/trashf-1.0.1.tar.gz")
+#sha256sums#=("SKIP")
+
+build() {
+ cd $srcdir/$pkgname-${pkgver}
+ python setup.py build
+}
+
+package() {
+ cd $srcdir/$pkgname-${pkgver}
+
+ python setup.py install --root="$pkgdir/" --optimize=1
+
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 README.md "$pkgdir/usr/lib/$pkgname/README.md"
+}