summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCan Celasun2015-05-31 21:46:22 +0300
committerCan Celasun2015-05-31 21:46:22 +0300
commit9690978365c259a57c035c132d0a255e57c03d85 (patch)
treeb574c297bdc974d232fcf264533aa7523f388d9c
downloadaur-trauma.tar.gz
New structure
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD65
-rw-r--r--trauma.desktop10
-rw-r--r--trauma.install11
-rw-r--r--trauma.pngbin0 -> 6718 bytes
-rwxr-xr-xtrauma.sh5
6 files changed, 110 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f40e173c377d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = trauma
+ pkgdesc = TRAUMA is a unique photographic experience by game designer Krystian Majewski. Dive into the mind of a traumatized young woman to learn and understand.
+ pkgver = 3
+ pkgrel = 4
+ url = http://www.traumagame.com/
+ install = trauma.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = flashplayer-standalone
+ source = trauma.png
+ source = trauma.desktop
+ source = trauma.sh
+ md5sums = 41951abca248a5e2f4831cab92b6c281
+ md5sums = 6560fcfccf2f48f955efdaab81413eda
+ md5sums = 618a5bd22abe98666d1e7980256e70ce
+
+pkgname = trauma
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fb639707eddd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,65 @@
+# Maintainer: D. Can Celasun <dcelasun[at]gmail[dot]com>
+
+pkgname=trauma
+pkgver=3
+pkgrel=4
+pkgdesc="TRAUMA is a unique photographic experience by game designer Krystian Majewski. Dive into the mind of a traumatized young woman to learn and understand."
+arch=('i686' 'x86_64')
+url="http://www.traumagame.com/"
+license=('custom')
+depends=('flashplayer-standalone')
+
+install="trauma.install"
+source=(trauma.png
+ trauma.desktop
+ trauma.sh)
+
+md5sums=('41951abca248a5e2f4831cab92b6c281'
+ '6560fcfccf2f48f955efdaab81413eda'
+ '618a5bd22abe98666d1e7980256e70ce')
+
+_gamepkg="trauma_3_all.tar"
+
+package () {
+ cd "${srcdir}"
+
+ msg "You need a full copy of this game in order to install it"
+ msg "Searching for ${_gamepkg} in dir: \"${startdir}\""
+ pkgpath="${startdir}"
+ if [[ ! -f "${startdir}/${_gamepkg}" ]]; then
+ error "Game package not found, please type absolute path to ${_gamepkg} (/home/joe):"
+ read pkgpath
+ if [[ ! -f "${pkgpath}/${_gamepkg}" ]]; then
+ error "Unable to find game package." && return 1
+ fi
+ fi
+ msg "Found game package, installing..."
+
+ ln -fs "${pkgpath}/${_gamepkg}" .
+ tar xvf "${pkgpath}/${_gamepkg}"
+
+ # create pkgdir folders
+ install -d "${pkgdir}"/usr/bin
+ install -d "${pkgdir}"/usr/share/{applications,games,icons}
+ install -d "${pkgdir}"/usr/share/games/${pkgname}
+
+ # install files
+ cp -r . "${pkgdir}/usr/share/games/${pkgname}"
+ find "${pkgdir}"/usr/share/games/${pkgname}/ -type d -exec chmod 0755 {} \;
+ find "${pkgdir}"/usr/share/games/${pkgname}/ -type f -exec chmod 0644 {} \;
+ chmod 0755 "${pkgdir}"/usr/share/games/${pkgname}/${pkgname}.sh
+ chmod 0755 "${pkgdir}"/usr/share/games/${pkgname}/${pkgname}.swf
+ chmod +x "${pkgdir}"/usr/share/games/${pkgname}/${pkgname}.swf
+ rm -rf "${pkgdir}"/usr/share/games/${pkgname}/flashplayer
+
+ # license
+ # I can't find a license for this game anywhere, not even in the game :(
+ #install -d "${pkgdir}"/usr/share/licenses/${pkgname}
+
+ # launch script
+ install -m755 "${srcdir}"/${pkgname}.sh "${pkgdir}"/usr/bin/${pkgname}
+
+ # icon/.desktop
+ install -Dm644 "${pkgname}.png" "${pkgdir}"/usr/share/icons/
+ install -Dm644 "${pkgname}.desktop" "${pkgdir}"/usr/share/applications/
+}
diff --git a/trauma.desktop b/trauma.desktop
new file mode 100644
index 000000000000..4f296a30810e
--- /dev/null
+++ b/trauma.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=Trauma
+Comment=Dive into the mind of a traumatized young woman to learn and understand.
+Version=1
+Type=Application
+Categories=Game;
+Icon=/usr/share/icons/trauma.png
+Exec=/usr/bin/trauma
+Encoding=UTF-8
+Terminal=false
diff --git a/trauma.install b/trauma.install
new file mode 100644
index 000000000000..6e9b764c7f0d
--- /dev/null
+++ b/trauma.install
@@ -0,0 +1,11 @@
+post_install() {
+ gtk-update-icon-cache
+}
+
+post_upgrade() {
+ gtk-update-icon-cache
+}
+
+post_remove() {
+ gtk-update-icon-cache
+}
diff --git a/trauma.png b/trauma.png
new file mode 100644
index 000000000000..3c46820c9281
--- /dev/null
+++ b/trauma.png
Binary files differ
diff --git a/trauma.sh b/trauma.sh
new file mode 100755
index 000000000000..c4d7e47cb82a
--- /dev/null
+++ b/trauma.sh
@@ -0,0 +1,5 @@
+#!/bin/bash
+
+cd "/usr/share/games/trauma"
+export PATH=./:$PATH
+/usr/bin/flashplayer ./trauma.swf