aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBuildTools2020-07-20 21:18:02 +1200
committerBuildTools2020-07-20 21:18:02 +1200
commit2951bc8906a396478b96940cd0913f27ce9bb7c5 (patch)
tree499a9c95beb5bd79a499dc4ebb7e8252d854952a
downloadaur-2951bc8906a396478b96940cd0913f27ce9bb7c5.tar.gz
Added Travertine
-rw-r--r--.SRCINFO36
-rw-r--r--PKGBUILD55
-rw-r--r--travertine-backup.service12
-rw-r--r--travertine-backup.timer10
-rw-r--r--travertine.conf28
-rw-r--r--travertine.install33
-rw-r--r--travertine.service13
-rwxr-xr-xtravertine.sh488
8 files changed, 675 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b6ca3086a09f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,36 @@
+pkgbase = travertine
+ pkgdesc = A fork of Waterfall to add 1.7, and other, protocol support.
+ pkgver = 153
+ pkgrel = 1
+ url = https://papermc.io/
+ install = travertine.install
+ arch = any
+ license = MIT
+ makedepends = wget
+ depends = java-runtime-headless>=8
+ depends = screen
+ depends = sudo
+ depends = bash
+ depends = awk
+ depends = sed
+ optdepends = tar: needed in order to create backups
+ optdepends = netcat: required in order to suspend an idle server
+ noextract = travertine.153.jar
+ backup = etc/conf.d/travertine
+ source = travertine.153.jar::https://papermc.io/ci/job/Travertine/lastSuccessfulBuild/artifact/Travertine-Proxy/bootstrap/target/Travertine.jar
+ source = travertine-backup.service
+ source = travertine-backup.timer
+ source = travertine.service
+ source = travertine.conf
+ source = travertine.sh
+ source = LICENSE.txt::https://raw.githubusercontent.com/PaperMC/Travertine/master/LICENSE.txt
+ sha512sums = SKIP
+ sha512sums = c33bfa44428b4b9dfb17abd8df613a7c9b61995417fe7cafe6444b499afe23208496f299f8df32b613520b8d886aa8da3c16824bfc7c6e2bd85def7ab12162bc
+ sha512sums = 8c7dd05ed781c9a5e7feb106e0e04c07bc2503d6a9fb1c9c642431d4d3cde099f3c801704a31d19512c3e89dbab57356a006c9f4284b652a7d1a6a172a3e83a2
+ sha512sums = 80847ed099d70d6d6c2735d2377520f9703445f4cebb38e39ffa69252da597c830448e36e13ab5b44c3b4aae9a08258db0e7ebd4f540da0b395c6c7504363fee
+ sha512sums = dbeca8fa04f7266b623491150ced524702e684d548ff121e7bdfe8035c6a0dcab23eee8baba8f3784329c0192dbdfac33f27966bb61cdea50318494d0fbcd2f9
+ sha512sums = eabfc7cd537156601ba525f79312db03a423fa6f8c8056d0148e19d56f30fe849bce685e35773b501be03196943da8e61976d35fbc7abe45e160a58aca6bc9b0
+ sha512sums = SKIP
+
+pkgname = travertine
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2046264a40d5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: Johannes Joens <johannes@joens.email>
+
+pkgname=travertine
+pkgver=153
+pkgrel=1
+_pkgver=`wget -qO- https://papermc.io/ci/job/Travertine/lastSuccessfulBuild/buildNumber`
+pkgdesc="A fork of Waterfall to add 1.7, and other, protocol support."
+arch=('any')
+url="https://papermc.io/"
+license=('MIT')
+depends=('java-runtime-headless>=8' 'screen' 'sudo' 'bash' 'awk' 'sed')
+optdepends=("tar: needed in order to create backups"
+ "netcat: required in order to suspend an idle server")
+makedepends=('wget')
+backup=('etc/conf.d/travertine')
+install="${pkgname}.install"
+source=("${pkgname}.${_pkgver}.jar"::"https://papermc.io/ci/job/Travertine/lastSuccessfulBuild/artifact/Travertine-Proxy/bootstrap/target/Travertine.jar"
+ "${pkgname}-backup.service"
+ "${pkgname}-backup.timer"
+ "${pkgname}.service"
+ "${pkgname}.conf"
+ "${pkgname}.sh"
+ "LICENSE.txt"::"https://raw.githubusercontent.com/PaperMC/Travertine/master/LICENSE.txt")
+noextract=("${pkgname}.${_pkgver}.jar")
+sha512sums=('SKIP'
+ 'c33bfa44428b4b9dfb17abd8df613a7c9b61995417fe7cafe6444b499afe23208496f299f8df32b613520b8d886aa8da3c16824bfc7c6e2bd85def7ab12162bc'
+ '8c7dd05ed781c9a5e7feb106e0e04c07bc2503d6a9fb1c9c642431d4d3cde099f3c801704a31d19512c3e89dbab57356a006c9f4284b652a7d1a6a172a3e83a2'
+ '80847ed099d70d6d6c2735d2377520f9703445f4cebb38e39ffa69252da597c830448e36e13ab5b44c3b4aae9a08258db0e7ebd4f540da0b395c6c7504363fee'
+ 'dbeca8fa04f7266b623491150ced524702e684d548ff121e7bdfe8035c6a0dcab23eee8baba8f3784329c0192dbdfac33f27966bb61cdea50318494d0fbcd2f9'
+ 'eabfc7cd537156601ba525f79312db03a423fa6f8c8056d0148e19d56f30fe849bce685e35773b501be03196943da8e61976d35fbc7abe45e160a58aca6bc9b0'
+ 'SKIP')
+pkgver() {
+ printf `wget -qO- https://papermc.io/ci/job/Travertine/lastSuccessfulBuild/buildNumber`
+}
+_game="${pkgname}"
+_server_root="/srv/${pkgname}"
+package() {
+ install -Dm644 ${_game}.conf "${pkgdir}/etc/conf.d/${_game}"
+ install -Dm755 ${_game}.sh "${pkgdir}/usr/bin/${_game}"
+ install -Dm644 ${_game}.service "${pkgdir}/usr/lib/systemd/system/${_game}.service"
+ install -Dm644 ${_game}-backup.service "${pkgdir}/usr/lib/systemd/system/${_game}-backup.service"
+ install -Dm644 ${_game}-backup.timer "${pkgdir}/usr/lib/systemd/system/${_game}-backup.timer"
+ install -Dm644 ${_game}.${_pkgver}.jar "${pkgdir}/${_server_root}/${_game}.${_pkgver}.jar"
+ ln -s "${_game}.${_pkgver}.jar" "${pkgdir}${_server_root}/${_game}_server.jar"
+
+ # Link the log files
+ mkdir -p "${pkgdir}/var/log/"
+ install -dm2755 "${pkgdir}/${_server_root}/logs"
+ ln -s "${_server_root}/logs" "${pkgdir}/var/log/${_game}"
+
+ # Give the group write permissions and set user or group ID on execution
+ chmod g+ws "${pkgdir}${_server_root}"
+
+ install -D ./LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
diff --git a/travertine-backup.service b/travertine-backup.service
new file mode 100644
index 000000000000..761067601984
--- /dev/null
+++ b/travertine-backup.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=Travertine Server World Backup
+After=local-fs.target
+
+[Service]
+Type=oneshot
+ExecStart=/usr/bin/travertine backup
+User=travertine
+Group=travertine
+
+[Install]
+WantedBy=multi-user.target
diff --git a/travertine-backup.timer b/travertine-backup.timer
new file mode 100644
index 000000000000..fb4e610f7df2
--- /dev/null
+++ b/travertine-backup.timer
@@ -0,0 +1,10 @@
+[Unit]
+Description=Daily Travertine Server Backup
+
+[Timer]
+OnCalendar=daily
+AccuracySec=5min
+Persistent=true
+
+[Install]
+WantedBy=multi-user.target
diff --git a/travertine.conf b/travertine.conf
new file mode 100644
index 000000000000..6efa2ec8411e
--- /dev/null
+++ b/travertine.conf
@@ -0,0 +1,28 @@
+# THIS IS THE CONFIGURATION FILE FOR THE MANAGING SCRIPT NOT FOR THE ACTUAL SERVER
+# Variables are interpreted in bash. Simply using bash-syntax is sufficient.
+
+# General parameters
+SERVER_ROOT="/srv/travertine"
+BACKUP_DEST="/srv/travertine/backup"
+BACKUP_PATHS="world" # World paths separated by spaces relative to SERVER_ROOT
+KEEP_BACKUPS="10"
+GAME_USER="travertine"
+MAIN_EXECUTABLE="travertine.jar"
+SESSION_NAME="travertine"
+
+# System parameters for java
+# -Xms sets the intial heap size (must be a multiple of 1024 and greater than 2MB, no spaces!)
+# -Xmx sets the maximum heap size (must be a multiple of 1024 and greater than 2MB, no spaces!)
+# -XX:ParallelGCThreads defines the number of threads the server may use
+SERVER_START_CMD="java -Xms512M -Xmx1024M -XX:ParallelGCThreads=1 -jar './${MAIN_EXECUTABLE}' nogui"
+
+# System parameters for the actual game server
+# Describes whether a daemon process which stops the server if it is not used by a player
+# within IDLE_IF_TIME seconds should be started. The GAME_PORT is not inhereted to the server!
+IDLE_SERVER=false # true or false
+# Ensure that if SESSION_NAME is passed through the command line and therefore set to read only by the script,
+# IDLE_SESSION_NAME gets altered according to the command line and not the configurtion file, hence invoke the variable
+IDLE_SESSION_NAME="idle_server_${SESSION_NAME}"
+GAME_PORT="25565" # used to listen for incoming connections when the server is down
+CHECK_PLAYER_TIME="30" # in seconds
+IDLE_IF_TIME="1200" # in seconds
diff --git a/travertine.install b/travertine.install
new file mode 100644
index 000000000000..768f37733031
--- /dev/null
+++ b/travertine.install
@@ -0,0 +1,33 @@
+_game="travertine"
+_user="travertine"
+_server_root="/srv/travertine"
+
+post_install() {
+ getent group "${_user}" &>/dev/null
+ if [ $? -ne 0 ]; then
+ echo "Adding ${_user} system group..."
+ groupadd -r ${_user} 1>/dev/null
+ fi
+
+ getent passwd "${_user}" &>/dev/null
+ if [ $? -ne 0 ]; then
+ echo "Adding ${_user} system user..."
+ useradd -r -g ${_user} -d "${_server_root}" ${_user} 1>/dev/null
+ fi
+
+ chown -R ${_user}:${_user} "${_server_root}"
+
+ echo "The server data is stored under ${_server_root} and the server runs as ${_user} user to increase security."
+ echo "Use the ${_game} script under /usr/bin/${_game} to start, stop or backup the server."
+ echo "Adjust the configuration file under /etc/conf.d/${_game} to your liking."
+}
+
+post_upgrade() {
+ chown -R ${_user}:${_user} "${_server_root}"
+}
+
+post_remove() {
+ # Notifying the user of kept dirs
+ [[ -d "${_server_root}" ]] && echo "Game saves in ${_server_root} were kept on your system."
+ echo "The ${_user} user was preserved on your system."
+}
diff --git a/travertine.service b/travertine.service
new file mode 100644
index 000000000000..3c934874ad80
--- /dev/null
+++ b/travertine.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=Travertine Server
+After=local-fs.target network.target multi-user.target
+
+[Service]
+Type=forking
+ExecStart=/usr/bin/travertine start
+ExecStop=/usr/bin/travertine stop
+User=travertine
+Group=travertine
+
+[Install]
+WantedBy=multi-user.target
diff --git a/travertine.sh b/travertine.sh
new file mode 100755
index 000000000000..6dda2a3105a9
--- /dev/null
+++ b/travertine.sh
@@ -0,0 +1,488 @@
+#!/bin/bash
+
+# The actual program name
+declare -r myname="travertine"
+declare -r game="travertine"
+
+# General rule for the variable-naming-schema:
+# Variables in capital letters may be passed through the command line others not.
+# Avoid altering any of those later in the code since they may be readonly (IDLE_SERVER is an exception!)
+
+# You may use this script for any game server of your choice, just alter the config file
+[[ -n "${SERVER_ROOT}" ]] && declare -r SERVER_ROOT=${SERVER_ROOT} || SERVER_ROOT="/srv/${game}"
+[[ -n "${BACKUP_DEST}" ]] && declare -r BACKUP_DEST=${BACKUP_DEST} || BACKUP_DEST="/srv/${game}/backup"
+[[ -n "${BACKUP_PATHS}" ]] && declare -r BACKUP_PATHS=${BACKUP_PATHS} || BACKUP_PATHS="world"
+[[ -n "${BACKUP_FLAGS}" ]] && declare -r BACKUP_FLAGS=${BACKUP_FLAGS} || BACKUP_FLAGS="-z"
+[[ -n "${KEEP_BACKUPS}" ]] && declare -r KEEP_BACKUPS=${KEEP_BACKUPS} || KEEP_BACKUPS="10"
+[[ -n "${GAME_USER}" ]] && declare -r GAME_USER=${GAME_USER} || GAME_USER="travertine"
+[[ -n "${MAIN_EXECUTABLE}" ]] && declare -r MAIN_EXECUTABLE=${MAIN_EXECUTABLE} || MAIN_EXECUTABLE="travertine_server.jar"
+[[ -n "${SESSION_NAME}" ]] && declare -r SESSION_NAME=${SESSION_NAME} || SESSION_NAME="${game}"
+
+# Command and parameter declaration with which to start the server
+[[ -n "${SERVER_START_CMD}" ]] && declare -r SERVER_START_CMD=${SERVER_START_CMD} || SERVER_START_CMD="java -Xms512M -Xmx1024M -XX:ParallelGCThreads=1 -jar './${MAIN_EXECUTABLE}' nogui"
+
+# System parameters for the control script
+[[ -n "${IDLE_SERVER}" ]] && tmp_IDLE_SERVER=${IDLE_SERVER} || IDLE_SERVER="false"
+[[ -n "${IDLE_SESSION_NAME}" ]] && declare -r IDLE_SESSION_NAME=${IDLE_SESSION_NAME} || IDLE_SESSION_NAME="idle_server_${SESSION_NAME}"
+[[ -n "${GAME_PORT}" ]] && declare -r GAME_PORT=${GAME_PORT} || GAME_PORT="25565"
+[[ -n "${CHECK_PLAYER_TIME}" ]] && declare -r CHECK_PLAYER_TIME=${CHECK_PLAYER_TIME} || CHECK_PLAYER_TIME="30"
+[[ -n "${IDLE_IF_TIME}" ]] && declare -r IDLE_IF_TIME=${IDLE_IF_TIME} || IDLE_IF_TIME="1200"
+
+# Additional configuration options which only few may need to alter
+[[ -n "${GAME_COMMAND_DUMP}" ]] && declare -r GAME_COMMAND_DUMP=${GAME_COMMAND_DUMP} || GAME_COMMAND_DUMP="/tmp/${myname}_${SESSION_NAME}_command_dump.txt"
+
+# Variables passed over the command line will always override the one from a config file
+source /etc/conf.d/"${game}" 2>/dev/null || >&2 echo "Could not source /etc/conf.d/${game}"
+
+# Preserve the content of IDLE_SERVER without making it readonly
+[[ -n ${tmp_IDLE_SERVER} ]] && IDLE_SERVER=${tmp_IDLE_SERVER}
+
+
+# Strictly disallow uninitialized Variables
+set -u
+# Exit if a single command breaks and its failure is not handled accordingly
+set -e
+
+# Check whether sudo is needed at all
+if [[ "$(whoami)" == "${GAME_USER}" ]]; then
+ SUDO_CMD=""
+else
+ SUDO_CMD="sudo -u ${GAME_USER}"
+fi
+
+# Choose which flavor of netcat is to be used
+if command -v netcat &> /dev/null; then
+ NETCAT_CMD="netcat"
+elif command -v ncat &> /dev/null; then
+ NETCAT_CMD="ncat"
+else
+ NETCAT_CMD=""
+fi
+
+# Check for sudo rigths
+if [[ "$(${SUDO_CMD} whoami)" != "${GAME_USER}" ]]; then
+ >&2 echo -e "You have \e[39;1mno permission\e[0m to run commands as $GAME_USER user."
+ exit 21
+fi
+
+# Pipe any given argument to the game server console,
+# sleep for $sleep_time and return its output if $return_stdout is set
+game_command() {
+ if [[ -z "${return_stdout:-}" ]]; then
+ ${SUDO_CMD} screen -S "${SESSION_NAME}" -X stuff "$(printf "%s\r" "$*")"
+ else
+ ${SUDO_CMD} screen -S "${SESSION_NAME}" -X log on
+ ${SUDO_CMD} screen -S "${SESSION_NAME}" -X stuff "$(printf "%s\r" "$*")"
+ sleep "${sleep_time:-0.3}"
+ ${SUDO_CMD} screen -S "${SESSION_NAME}" -X log off
+ ${SUDO_CMD} cat "${GAME_COMMAND_DUMP}"
+ ${SUDO_CMD} rm "${GAME_COMMAND_DUMP}"
+ fi
+}
+
+# Check whether there are player on the server through list
+is_player_online() {
+ response="$(sleep_time=0.6 return_stdout=true game_command list)"
+ # Delete leading line and free response string from fancy characters
+ response="$(echo "${response}" | sed -r -e 's/\x1B\[([0-9]{1,2}(;[0-9]{1,2})*)?[JKmsuG]//g')"
+ # The list command prints a line containing the usernames after the last occurrence of ": "
+ # and since playernames may not contain this string the clean player-list can easily be retrieved.
+ # Otherwise check the first digit after the last occurrence of "There are". If it is 0 then there
+ # are no players on the server. Should this test fail as well. Assume that a player is online.
+ if [[ $(echo "${response}" | grep ":" | sed -e 's/.*\: //' | tr -d '\n' | wc -c) -le 1 ]]; then
+ # No player is online
+ return 0
+ elif [[ "x$(echo "${response}" | grep "There are" | sed -r -e 's/.*\: //' -e 's/^([^.]+).*$/\1/; s/^[^0-9]*([0-9]+).*$/\1/' | tr -d '\n')" == "x0" ]]; then
+ # No player is online
+ return 0
+ else
+ # A player is online (or it could not be determined)
+ return 1
+ fi
+}
+
+# Check whether the server is visited by a player otherwise shut it down
+idle_server_daemon() {
+ # This function is run within a screen session of the GAME_USER therefore SUDO_CMD can be omitted
+ if [[ "$(whoami)" != "${GAME_USER}" ]]; then
+ >&2 echo "Somehow this hidden function was not executed by the ${GAME_USER} user."
+ >&2 echo "This should not have happend. Are you messing around with this script? :P"
+ exit 22
+ fi
+
+ # Time in seconds for which no player was on the server
+ no_player=0
+
+ while true; do
+ echo -e "no_player: ${no_player}s\tcheck_player_time: ${CHECK_PLAYER_TIME}s\tidle_if_time: ${IDLE_IF_TIME}s"
+ # Retry in ${CHECK_PLAYER_TIME} seconds
+ sleep ${CHECK_PLAYER_TIME}
+
+ if screen -S "${SESSION_NAME}" -Q select . > /dev/null; then
+ # Game server is up and running
+ if [[ "$(screen -S "${SESSION_NAME}" -ls | sed -n "s/.*${SESSION_NAME}\s\+//gp")" == "(Attached)" ]]; then
+ # An administrator is connected to the console, pause player checking
+ echo "An admin is connected to the console. Pause player checking."
+ # Check for active player
+ elif SUDO_CMD="" is_player_online; then
+ # No player was seen on the server through list
+ no_player=$(( no_player + CHECK_PLAYER_TIME ))
+ # Stop the game server if no player was active for at least ${IDLE_IF_TIME}
+ if [[ "${no_player}" -ge "${IDLE_IF_TIME}" ]]; then
+ IDLE_SERVER="false" ${myname} stop
+ # Wait for game server to go down
+ for i in {1..100}; do
+ screen -S "${SESSION_NAME}" -Q select . > /dev/null || break
+ [[ $i -eq 100 ]] && echo -e "An \e[39;1merror\e[0m occurred while trying to reset the idle_server!"
+ sleep 0.1
+ done
+ # Reset timer and give the player 300 seconds to connect after pinging
+ no_player=$(( IDLE_IF_TIME - 300 ))
+ # Game server is down, listen on port ${GAME_PORT} for incoming connections
+ echo -n "Netcat: "
+ ${NETCAT_CMD} -v -l -p ${GAME_PORT} && echo "Netcat caught an connection. The server is coming up again..."
+ IDLE_SERVER="false" ${myname} start
+ fi
+ else
+ # Reset timer since there is an active player on the server
+ no_player=0
+ fi
+ else
+ # Reset timer and give the player 300 seconds to connect after pinging
+ no_player=$(( IDLE_IF_TIME - 300 ))
+ # Game server is down, listen on port ${GAME_PORT} for incoming connections
+ echo -n "Netcat: "
+ ${NETCAT_CMD} -v -l -p ${GAME_PORT} && echo "Netcat caught an connection. The server is coming up again..."
+ IDLE_SERVER="false" ${myname} start
+ fi
+ done
+}
+
+# Start the server if it is not already running
+server_start() {
+ # Start the game server
+ if ${SUDO_CMD} screen -S "${SESSION_NAME}" -Q select . > /dev/null; then
+ echo "A screen ${SESSION_NAME} session is already running. Please close it first."
+ else
+ echo -en "Starting server..."
+ ${SUDO_CMD} screen -dmS "${SESSION_NAME}" /bin/bash -c "cd '${SERVER_ROOT}'; ${SERVER_START_CMD}"
+ ${SUDO_CMD} screen -S "${SESSION_NAME}" -X logfile "${GAME_COMMAND_DUMP}"
+ echo -e "\e[39;1m done\e[0m"
+ fi
+
+ if [[ "${IDLE_SERVER,,}" == "true" ]]; then
+ # Check for the availability of the netcat (nc) binaries
+ if [[ -z "${NETCAT_CMD}" ]]; then
+ >&2 echo "The netcat binaries are needed for suspending an idle server."
+ exit 12
+ fi
+
+ # Start the idle server daemon
+ if ${SUDO_CMD} screen -S "${IDLE_SESSION_NAME}" -Q select . > /dev/null; then
+ ${SUDO_CMD} screen -S "${IDLE_SESSION_NAME}" -X quit
+ # Restart as soon as the idle_server_daemon has shut down completely
+ for i in {1..100}; do
+ if ! ${SUDO_CMD} screen -S "${IDLE_SESSION_NAME}" -Q select . > /dev/null; then
+ ${SUDO_CMD} screen -dmS "${IDLE_SESSION_NAME}" /bin/bash -c "${myname} idle_server_daemon"
+ break
+ fi
+ [[ $i -eq 100 ]] && echo -e "An \e[39;1merror\e[0m occurred while trying to reset the idle_server!"
+ sleep 0.1
+ done
+ else
+ echo -en "Starting idle server daemon..."
+ ${SUDO_CMD} screen -dmS "${IDLE_SESSION_NAME}" /bin/bash -c "${myname} idle_server_daemon"
+ echo -e "\e[39;1m done\e[0m"
+ fi
+ fi
+}
+
+# Stop the server gracefully by saving everything prior and warning the users
+server_stop() {
+ # Quit the idle daemon
+ if [[ "${IDLE_SERVER,,}" == "true" ]]; then
+ # Check for the availability of the netcat (nc) binaries
+ if [[ -z "${NETCAT_CMD}" ]]; then
+ >&2 echo "The netcat binaries are needed for suspending an idle server."
+ exit 12
+ fi
+
+ if ${SUDO_CMD} screen -S "${IDLE_SESSION_NAME}" -Q select . > /dev/null; then
+ echo -en "Stopping idle server daemon..."
+ ${SUDO_CMD} screen -S "${IDLE_SESSION_NAME}" -X quit
+ echo -e "\e[39;1m done\e[0m"
+ else
+ echo "The corresponding screen session for ${IDLE_SESSION_NAME} was already dead."
+ fi
+ fi
+
+ # Gracefully exit the game server
+ if ${SUDO_CMD} screen -S "${SESSION_NAME}" -Q select . > /dev/null; then
+ # Game server is up and running, gracefully stop the server when there are still active players
+
+ # Check for active player
+ if is_player_online; then
+ # No player was seen on the server through list
+ echo -en "Server is going down..."
+ game_command end
+ else
+ # Player(s) were seen on the server through list (or an error occurred)
+ # Warning the users through the server console
+ game_command alert "Server is going down in 10 seconds! HURRY UP WITH WHATEVER YOU ARE DOING!"
+ echo -en "Server is going down in..."
+ for i in {1..10}; do
+ game_command alert "down in... $(( 10 - i ))"
+ echo -n " $(( 10 - i ))"
+ sleep 1
+ done
+ game_command end
+ fi
+
+ # Finish as soon as the server has shut down completely
+ for i in {1..100}; do
+ if ! ${SUDO_CMD} screen -S "${SESSION_NAME}" -Q select . > /dev/null; then
+ echo -e "\e[39;1m done\e[0m"
+ break
+ fi
+ [[ $i -eq 100 ]] && echo -e "\e[39;1m timed out\e[0m"
+ sleep 0.1
+ done
+ else
+ echo "The corresponding screen session for ${SESSION_NAME} was already dead."
+ fi
+}
+
+# Print whether the server is running and if so give some information about memory usage and threads
+server_status() {
+ # Print status information about the idle daemon
+ if [[ "${IDLE_SERVER,,}" == "true" ]]; then
+ # Check for the availability of the netcat (nc) binaries
+ if [[ -z "${NETCAT_CMD}" ]]; then
+ >&2 echo "The netcat binaries are needed for suspending an idle server."
+ exit 12
+ fi
+
+ if ${SUDO_CMD} screen -S "${IDLE_SESSION_NAME}" -Q select . > /dev/null; then
+ echo -e "Idle server daemon status:\e[39;1m running\e[0m"
+ else
+ echo -e "Idle server daemon status:\e[39;1m stopped\e[0m"
+ fi
+ fi
+
+ # Print status information for the game server
+ if ${SUDO_CMD} screen -S "${SESSION_NAME}" -Q select . > /dev/null; then
+ echo -e "Status:\e[39;1m running\e[0m"
+
+ # Calculating memory usage
+ for p in $(${SUDO_CMD} pgrep -f "${MAIN_EXECUTABLE}"); do
+ ps -p"${p}" -O rss | tail -n 1;
+ done | gawk '{ count ++; sum += $2 }; END {count --; print "Number of processes =", count, "(screen, bash,", count-2, "x server)"; print "Total memory usage =", sum/1024, "MB" ;};'
+ else
+ echo -e "Status:\e[39;1m stopped\e[0m"
+ fi
+}
+
+# Restart the complete server by shutting it down and starting it again
+server_restart() {
+ if ${SUDO_CMD} screen -S "${SESSION_NAME}" -Q select . > /dev/null; then
+ server_stop
+ server_start
+ else
+ server_start
+ fi
+}
+
+# Backup the directories specified in BACKUP_PATHS
+backup_files() {
+ # Check for the availability of the tar binaries
+ if ! command -v tar &> /dev/null; then
+ >&2 echo "The tar binaries are needed for a backup."
+ exit 11
+ fi
+
+ echo "Starting backup..."
+ fname="$(date +%Y_%m_%d_%H.%M.%S).tar.gz"
+ ${SUDO_CMD} mkdir -p "${BACKUP_DEST}"
+ if ${SUDO_CMD} screen -S "${SESSION_NAME}" -Q select . > /dev/null; then
+ sync && wait
+ ${SUDO_CMD} tar -C "${SERVER_ROOT}" -cf "${BACKUP_DEST}/${fname}" ${BACKUP_PATHS} --totals ${BACKUP_FLAGS} 2>&1 | grep -v "tar: Removing leading "
+ else
+ ${SUDO_CMD} tar -C "${SERVER_ROOT}" -cf "${BACKUP_DEST}/${fname}" ${BACKUP_PATHS} --totals ${BACKUP_FLAGS} 2>&1 | grep -v "tar: Removing leading "
+ fi
+ echo -e "\e[39;1mbackup completed\e[0m\n"
+
+ echo -n "Only keeping the last ${KEEP_BACKUPS} backups and removing the other ones..."
+ backup_count=$(for f in "${BACKUP_DEST}"/[0-9_.]*; do echo "${f}"; done | wc -l)
+ if [[ $(( backup_count - KEEP_BACKUPS )) -gt 0 ]]; then
+ for old_backup in $(for f in "${BACKUP_DEST}"/[0-9_.]*; do echo "${f}"; done | head -n"$(( backup_count - KEEP_BACKUPS ))"); do
+ ${SUDO_CMD} rm "${old_backup}";
+ done
+ echo -e "\e[39;1m done\e[0m ($(( backup_count - KEEP_BACKUPS)) backup(s) pruned)"
+ else
+ echo -e "\e[39;1m done\e[0m (no backups pruned)"
+ fi
+}
+
+# Restore backup
+backup_restore() {
+ # Check for the availability of the tar binaries
+ if ! command -v tar &> /dev/null; then
+ >&2 echo "The tar binaries are needed for a backup."
+ exit 11
+ fi
+
+ # Only allow the user to restore a backup if the server is down
+ if ${SUDO_CMD} screen -S "${SESSION_NAME}" -Q select . > /dev/null; then
+ >&2 echo -e "The \e[39;1mserver should be down\e[0m in order to restore the world data."
+ exit 3
+ fi
+
+ # Either let the user choose a backup or expect one as an argument
+ if [[ $# -lt 1 ]]; then
+ echo "Please enter the corresponding number for the backup to be restored: "
+ i=1
+ for f in "${BACKUP_DEST}"/[0-9_.]*; do
+ echo -e " \e[39;1m$i)\e[0m\t$f"
+ i=$(( i + 1 ))
+ done
+ echo -en "Restore backup number: "
+
+ # Read in user input
+ read -r user_choice
+
+ # Interpeting the input
+ if [[ $user_choice =~ ^-?[0-9]+$ ]]; then
+ n=1
+ for f in "${BACKUP_DEST}"/[0-9_.]*; do
+ [[ ${n} -eq $user_choice ]] && fname="$f"
+ n=$(( n + 1 ))
+ done
+ if [[ -z $fname ]]; then
+ >&2 echo -e "\e[39;1mFailed\e[0m to interpret your input. Please enter the digit of the presented options."
+ exit 5
+ fi
+ else
+ >&2 echo -e "\e[39;1mFailed\e[0m to interpret your input. Please enter a valid digit for one of the presented options."
+ exit 6
+ fi
+ elif [[ $# -eq 1 ]]; then
+ # Check for the existance of the specified file
+ if [[ -f "$1" ]]; then
+ fname="$1"
+ else
+ if [[ -f "${BACKUP_DEST}"/"$1" ]]; then
+ fname="${BACKUP_DEST}"/"$1"
+ else
+ >&2 echo -e "Sorry, but '$1', is \e[39;1mnot a valid file\e[0m, neither in your current directory nor in the backup folder."
+ exit 4
+ fi
+ fi
+ elif [[ $# -gt 1 ]]; then
+ >&2 echo -e "\e[39;1mToo many arguments.\e[0m Please pass only the filename for the world data as an argument."
+ >&2 echo "Or alternatively no arguments at all to chose from a list of available backups."
+ exit 7
+ fi
+
+ echo "Restoring backup..."
+ if ${SUDO_CMD} tar -xf "${fname}" -C "${SERVER_ROOT}" 2>&1; then
+ echo -e "\e[39;1mRestoration completed\e[0m"
+ else
+ echo -e "\e[39;1mFailed to restore backup.\e[0m"
+ fi
+}
+
+# Run the given comman at the game server console
+server_command() {
+ if [[ $# -lt 1 ]]; then
+ >&2 echo "No server command specified. Try 'help' for a list of commands."
+ exit 1
+ fi
+
+ if ${SUDO_CMD} screen -S "${SESSION_NAME}" -Q select . > /dev/null; then
+ return_stdout=true game_command "$@"
+ else
+ echo "There is no ${SESSION_NAME} session to connect to."
+ fi
+}
+
+# Enter the screen game session
+server_console() {
+ if ${SUDO_CMD} screen -S "${SESSION_NAME}" -Q select . > /dev/null; then
+ # Circumvent a permission bug related to running GNU screen as a different user,
+ # see e.g. https://serverfault.com/questions/116775/sudo-as-different-user-and-running-screen
+ ${SUDO_CMD} script -q -c "screen -S \"${SESSION_NAME}\" -rx" /dev/null
+ else
+ echo "There is no ${SESSION_NAME} session to connect to."
+ fi
+}
+
+# Help function, no arguments required
+help() {
+ cat <<-EOF
+ This script was design to easily control any ${game} server. Quite every parameter for a given
+ ${game} server derivative can be altered by editing the variables in the configuration file.
+
+ Usage: ${myname} {start|stop|status|backup|restore|command <command>|console}
+ start Start the ${game} server
+ stop Stop the ${game} server
+ restart Restart the ${game} server
+ status Print some status information
+ backup Backup the world data
+ restore [filename] Restore the world data from a backup
+ command <command> Run the given comman at the ${game} server console
+ console Enter the server console through a screen session
+
+ Copyright (c) Gordian Edenhofer <gordian.edenhofer@gmail.com>
+ EOF
+}
+
+case "${1:-}" in
+ start)
+ server_start
+ ;;
+
+ stop)
+ server_stop
+ ;;
+
+ status)
+ server_status
+ ;;
+
+ restart)
+ server_restart
+ ;;
+
+ console)
+ server_console
+ ;;
+
+ command)
+ server_command "${@:2}"
+ ;;
+
+ backup)
+ backup_files
+ ;;
+
+ restore)
+ backup_restore "${@:2}"
+ ;;
+
+ idle_server_daemon)
+ # This shall be a hidden function which should only be invoced internally
+ idle_server_daemon
+ ;;
+
+ -h|--help)
+ help
+ exit 0
+ ;;
+
+ *)
+ help
+ exit 1
+ ;;
+esac
+
+exit 0