summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael von Domaros2020-11-10 13:47:50 -0800
committerMichael von Domaros2020-11-10 13:47:50 -0800
commitb2365efdcd976410155cc8fc751f48631df7cc50 (patch)
treefec5356f4cf393cd932894cdd48046c10d514a92
parented40b5b4fc8e73e9222b23b5dfcd04f3239dd93d (diff)
downloadaur-b2365efdcd976410155cc8fc751f48631df7cc50.tar.gz
200504-hf2 update
-rw-r--r--PKGBUILD23
1 files changed, 17 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5491a4c09bfb..b07b68f97098 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
# Maintainer: Michael von Domaros <mvondomaros at gmail dot com>
+
pkgname=travis
-pkgver=180604
+pkgver=200504
pkgrel=1
pkgdesc="Trajectory Analyzer and Visualizer"
arch=('i686' 'x86_64')
@@ -8,15 +9,25 @@ url="http://www.travis-analyzer.de"
license=('GPL3')
depends=('gcc-libs')
options=('!strip')
-source=($url/files/$pkgname-src-$pkgver.tar.gz)
-md5sums=('44b3bfc36d40707a991ab6ebfc7ce84c')
+source=($url/files/$pkgname-src-$pkgver-hf2.tar.gz)
+md5sums=('c724e4170080db8f6e1cf5c0bc8d5013')
+
+_cdsrcdir() {
+ cd "$srcdir/$pkgname-src-$pkgver-hf2"
+}
+
+prepare() {
+ _cdsrcdir
+ sed -i '/CFLAGS \+=/d' Makefile
+}
build() {
- cd "$srcdir/$pkgname-src-$pkgver"
- make CFLAGS="$CFLAGS -ansi"
+ _cdsrcdir
+ export CFLAGS="-g -ansi -O3 -march=native"
+ make
}
package() {
- cd "$srcdir/$pkgname-src-$pkgver"
+ _cdsrcdir
install -Dm 755 exe/travis $pkgdir/usr/bin/travis
}