summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAllison Smith2023-08-11 21:21:54 +1000
committerAllison Smith2023-08-11 21:21:54 +1000
commit746d1aa2b074941e796ce7c58fd5d0094f58c197 (patch)
tree8a3e74fd96d4ae6969b3304b10a1286601b6b7a5
downloadaur-746d1aa2b074941e796ce7c58fd5d0094f58c197.tar.gz
initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD31
-rw-r--r--treedome-bin.install13
4 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..af15dc1008ee
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = treedome-bin
+ pkgdesc = A local-first, encrypted, note taking application with tree-like structures, all written and saved in markdown
+ pkgver = 0.3
+ pkgrel = 1
+ url = https://gitlab.com/treedome
+ install = treedome-bin.install
+ arch = x86_64
+ groups =
+ license = GPL3
+ depends = cairo
+ depends = desktop-file-utils
+ depends = gdk-pixbuf2
+ depends = glib2
+ depends = gtk3
+ depends = hicolor-icon-theme
+ depends = libsoup
+ depends = pango
+ depends = webkit2gtk
+ options = !strip
+ options = !emptydirs
+ source = https://gitlab.com/treedome/treedome/-/jobs/4843920279/artifacts/download
+ sha512sums = 0bc8cd64df6671cf9026d2a60605ec0ee13b371f4f8a567ffba4e45aad31b1e85c6c0a50400f025d325db12b4be471f3aa27dafdebfd4af666a24b954397dd3d
+
+pkgname = treedome-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..98d2bdfdd08e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*.deb
+*.pkg.*
+download
+
+src/
+pkg/ \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5768d8523211
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Generated by debtap
+# Maintainer: Allison Smith <alyway@protonmail.com>
+# Contributor:
+
+pkgname=treedome-bin
+pkgver=0.3
+pkgrel=1
+pkgdesc="A local-first, encrypted, note taking application with tree-like structures, all written and saved in markdown"
+arch=('x86_64')
+url="https://gitlab.com/treedome"
+license=('GPL3')
+groups=('')
+depends=('cairo' 'desktop-file-utils' 'gdk-pixbuf2' 'glib2' 'gtk3' 'hicolor-icon-theme' 'libsoup' 'pango' 'webkit2gtk')
+options=('!strip' '!emptydirs')
+install=${pkgname}.install
+source=("https://gitlab.com/treedome/treedome/-/jobs/4843920279/artifacts/download")
+sha512sums=('0bc8cd64df6671cf9026d2a60605ec0ee13b371f4f8a567ffba4e45aad31b1e85c6c0a50400f025d325db12b4be471f3aa27dafdebfd4af666a24b954397dd3d')
+
+prepare(){
+
+ # Dev may change the release to not be a .deb inside a .zip
+ ar vx treedome_amd64.deb
+
+}
+
+package(){
+
+ # Extract package data
+ tar -xz -f data.tar.gz -C "${pkgdir}"
+
+}
diff --git a/treedome-bin.install b/treedome-bin.install
new file mode 100644
index 000000000000..b50ffb36e4a2
--- /dev/null
+++ b/treedome-bin.install
@@ -0,0 +1,13 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ update-desktop-database -q
+}