summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLoïc Damien2016-07-02 16:06:34 +0200
committerLoïc Damien2016-07-02 16:06:34 +0200
commit6313893a49f928d1d7c266ad27ba76919f55ae42 (patch)
tree6b56632407095b373a70290e64a28780e5101b03
downloadaur-6313893a49f928d1d7c266ad27ba76919f55ae42.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4754943e55fd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = treeify
+ pkgdesc = converts the output of a command that lists files into a tree representation similar to the output of the command tree
+ pkgver = 0.1.3
+ pkgrel = 1
+ url = https://github.com/dzamlo/treeify
+ arch = i686
+ arch = x86_64
+ license = MIT
+ license = Apache
+ makedepends = cargo
+ depends = gcc-libs
+ source = https://github.com/dzamlo/treeify/archive/treeify-0.1.3.tar.gz
+ sha256sums = 55e27fc14e40c76c61e5eeb01e5bce1720e15f4ed489056d27ce81e2b3440a21
+
+pkgname = treeify
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bbad9276b247
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Loïc Damien <loic.damien at dzamlo dot ch>
+pkgname=treeify
+pkgver=0.1.3
+pkgrel=1
+pkgdesc="converts the output of a command that lists files into a tree representation similar to \
+ the output of the command tree"
+arch=('i686' 'x86_64')
+url="https://github.com/dzamlo/treeify"
+license=('MIT' 'Apache')
+depends=(gcc-libs)
+makedepends=(cargo)
+source=("https://github.com/dzamlo/treeify/archive/treeify-0.1.3.tar.gz")
+sha256sums=('55e27fc14e40c76c61e5eeb01e5bce1720e15f4ed489056d27ce81e2b3440a21')
+
+build() {
+ cd "$pkgname-$pkgname-$pkgver"
+
+ cargo build --release
+}
+
+package() {
+ cd "$pkgname-$pkgname-$pkgver"
+
+ install -Dm755 "target/release/$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 "target/release/build/$pkgname-"*"/out/${pkgname}_bash.sh" \
+ "$pkgdir/usr/share/bash-completion/completions/$pkgname"
+}