summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjustforlxz2024-01-10 20:28:08 +0800
committerjustforlxz2024-01-10 20:28:08 +0800
commit20c810cfd1955034fd0cdcc856aef0071583a7da (patch)
tree1d21cd76a0eba698c9adab99b753215072376d50
downloadaur-20c810cfd1955034fd0cdcc856aef0071583a7da.tar.gz
init
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD29
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9efee16752c2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = treeland
+ pkgdesc = a new wayland compositer for DDE
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://github.com/linuxdeepin/treeland
+ arch = x86_64
+ arch = aarch64
+ groups = deepin
+ license = LGPL3
+ makedepends = git
+ makedepends = qt6-tools
+ makedepends = waylib-git
+ makedepends = cmake
+ makedepends = ninja
+ depends = qt6-declarative
+ source = https://github.com/linuxdeepin/treeland/archive/0.1.1/treeland-0.1.1.tar.gz
+ sha512sums = SKIP
+
+pkgname = treeland
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..df213567a071
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: zccrs <zhangjide@deepin.org>
+pkgname=treeland
+pkgver=0.1.1
+pkgrel=1
+pkgdesc='a new wayland compositer for DDE'
+arch=('x86_64' 'aarch64')
+url="https://github.com/linuxdeepin/treeland"
+license=('LGPL3')
+depends=('qt6-declarative')
+makedepends=('git' 'qt6-tools' 'waylib-git' 'cmake' 'ninja')
+groups=('deepin')
+source=("https://github.com/linuxdeepin/treeland/archive/$pkgver/$pkgname-$pkgver.tar.gz")
+sha512sums=('SKIP')
+
+build() {
+ cd $pkgname-$pkgver
+ cmake -GNinja \
+ -DCMAKE_INSTALL_LIBEXECDIR=libexec \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release
+
+ cmake --build .
+}
+
+package() {
+ cd $pkgname-$pkgver
+ DESTDIR="$pkgdir" ninja install
+}