summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjustforlxz2024-01-10 20:22:04 +0800
committerjustforlxz2024-01-10 20:22:04 +0800
commit621389b6e2484a030acba11a5c6ce53e4fcbc288 (patch)
treeb4757d788c1a5a58232f2fc06724cb48bf29e02e
downloadaur-621389b6e2484a030acba11a5c6ce53e4fcbc288.tar.gz
init
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD39
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d979bcb1e990
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = treeland-git
+ pkgdesc = a new wayland compositer for DDE
+ pkgver = 0.1.1.r34.gbe6809f
+ pkgrel = 1
+ url = https://github.com/linuxdeepin/treeland
+ arch = x86_64
+ arch = aarch64
+ groups = deepin-git
+ license = LGPL3
+ makedepends = git
+ makedepends = qt6-tools
+ makedepends = waylib-git
+ makedepends = cmake
+ makedepends = ninja
+ depends = qt6-declarative
+ provides = treeland
+ conflicts = treeland
+ source = git+https://github.com/linuxdeepin/treeland
+ sha512sums = SKIP
+
+pkgname = treeland-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..46cd3bde52b9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: zccrs <zhangjide@deepin.org>
+pkgname=treeland-git
+pkgver=0.1.1.r34.gbe6809f
+pkgrel=1
+sourcename=treeland
+sourcetars=("$sourcename"_"$pkgver".tar.xz)
+sourcedir="$sourcename"
+pkgdesc='a new wayland compositer for DDE'
+arch=('x86_64' 'aarch64')
+url="https://github.com/linuxdeepin/treeland"
+license=('LGPL3')
+depends=('qt6-declarative')
+makedepends=('git' 'qt6-tools' 'waylib-git' 'cmake' 'ninja')
+conflicts=('treeland')
+provides=('treeland')
+groups=('deepin-git')
+source=("git+${url}")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd $sourcedir
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd $sourcedir
+ cmake -GNinja \
+ -DCMAKE_INSTALL_LIBEXECDIR=libexec \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release
+
+ cmake --build .
+}
+
+package() {
+ cd $sourcedir
+ DESTDIR="$pkgdir" ninja install
+}