summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoseph Diza2022-05-09 00:33:10 -0700
committerJoseph Diza2022-05-09 00:33:10 -0700
commit281566a94451324da0ce4db4acdb8fb754578caa (patch)
tree69bdf3d70ccf532bea9ea8341f71dba57bec5b15
downloadaur-281566a94451324da0ce4db4acdb8fb754578caa.tar.gz
Add initial .SRCINFO, PKGBUILD
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..20099b2c1972
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = treeleaves-git
+ pkgver = 0.3.1
+ pkgrel = 1
+ url = https://github.com/jmdaemon/treeleaves
+ arch = any
+ license = AGPL3
+ makedepends = git
+ makedepends = make
+ depends = sbcl
+ provides = treeleaves
+ conflicts = treeleaves
+ options = !strip
+ source = treeleaves-git::git+https://github.com/jmdaemon/treeleaves#branch=master
+ sha512sums = SKIP
+
+pkgname = treeleaves-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ec790e279463
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+pkgname=treeleaves-git
+pkgver=0.3.1
+pkgrel=1
+arch=('any')
+pkgdesc=''
+url='https://github.com/jmdaemon/treeleaves'
+license=('AGPL3')
+options=(!strip) # Mandatory as stripping the binary removes the sbcl runtime
+depends=('sbcl')
+optdepends=()
+makedepends=('git' 'make')
+source=("$pkgname::git+https://github.com/jmdaemon/treeleaves#branch=master")
+provides=(treeleaves)
+conflicts=(treeleaves)
+sha512sums=("SKIP")
+
+build() {
+ cd "$pkgname"
+ make build
+}
+
+package-bin() {
+ BIN_DIR="$pkgdir"/usr/bin
+ mkdir -p $BIN_DIR
+ install bin/treeleaves "$BIN_DIR/treeleaves"
+}
+
+package() {
+ cd "$pkgname"
+ package-bin
+}