summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKim Scarborough2018-12-30 13:51:43 -0600
committerKim Scarborough2018-12-30 13:51:43 -0600
commite5bbef3e4c90f36189ca8ad443c260218549ece5 (patch)
tree66baef56f4cfd0726b1c791880c75f159f0ed0cc
downloadaur-e5bbef3e4c90f36189ca8ad443c260218549ece5.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD23
-rw-r--r--treeline.xml8
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ba1d2a118c4d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = treeline
+ pkgdesc = Outliner and PIM which stores information in a tree structure
+ pkgver = 3.0.3
+ pkgrel = 1
+ url = http://treeline.bellz.org/
+ arch = any
+ license = GPL2
+ depends = python-lxml
+ depends = python-pyqt5
+ optdepends = aspell
+ optdepends = ispell
+ optdepends = hunspell
+ conflicts = treeline-unstable
+ source = https://github.com/doug-101/TreeLine/releases/download/v3.0.3/treeline-3.0.3.tar.gz
+ source = treeline.xml
+ sha256sums = 9591b439ecb7596fc44f0795c776918fc98af4db53c6bb68b7feb3d2108461c0
+ sha256sums = 2b23717127a37888499bddf62042eddb800d58b10ec88f3f54a538c8e24b19d6
+
+pkgname = treeline
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6a2feb532728
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Contributor: Kim Scarborough <sluggo@unknown.nu>
+
+pkgname=treeline
+pkgver=3.0.3
+pkgrel=1
+pkgdesc="Outliner and PIM which stores information in a tree structure"
+arch=('any')
+url="http://treeline.bellz.org/";
+license=('GPL2')
+depends=('python-lxml' 'python-pyqt5')
+optdepends=('aspell' 'ispell' 'hunspell')
+conflicts=('treeline-unstable')
+source=("https://github.com/doug-101/TreeLine/releases/download/v${pkgver}/treeline-${pkgver}.tar.gz"
+ "treeline.xml")
+sha256sums=('9591b439ecb7596fc44f0795c776918fc98af4db53c6bb68b7feb3d2108461c0'
+ '2b23717127a37888499bddf62042eddb800d58b10ec88f3f54a538c8e24b19d6')
+
+package() {
+ install -Dm644 treeline.xml "${pkgdir}/usr/share/mime/packages/x-treeline.xml"
+ cd "${srcdir}/TreeLine"
+ python install.py -p /usr -b "${pkgdir}"
+ install -Dm644 treeline.desktop "${pkgdir}/usr/share/applications/treeline.desktop"
+}
diff --git a/treeline.xml b/treeline.xml
new file mode 100644
index 000000000000..fbf50e5e96b2
--- /dev/null
+++ b/treeline.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0"?>
+<mime-info xmlns='http://www.freedesktop.org/standards/shared-mime-info'>
+ <mime-type type="application/x-treeline">
+ <comment>TreeLine database</comment>
+ <glob pattern="*.trln"/>
+ <glob pattern="*.trl"/>
+ </mime-type>
+</mime-info>