summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorge Angelopoulos2018-07-02 13:59:51 +0200
committerGeorge Angelopoulos2018-07-02 13:59:51 +0200
commit642dcbd4225942588c40845b8da4f14914829f3a (patch)
tree12f78632e5ce6d1ecabf2f7ce837fb2c0f0beae0
downloadaur-642dcbd4225942588c40845b8da4f14914829f3a.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD23
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6e45329a193d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Mon Jul 2 11:53:38 UTC 2018
+pkgbase = tremc
+ pkgdesc = Curses interface for transmission - python3 fork of transmission-remote-cli
+ pkgver = 0.9.1
+ pkgrel = 1
+ url = https://github.com/tremc/tremc
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = python
+ optdepends = python-geoip: Guess which country peers come from
+ optdepends = python-xerox: Copy magnet links to the system clipboard
+ replaces = tremc-git
+ source = https://github.com/tremc/tremc/archive/v0.9.1.tar.gz
+ md5sums = 08262de033014bf19cde91f1f27cf264
+
+pkgname = tremc
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c1f6cf7f1528
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src
+pkg
+*.tar.gz
+*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fa1a8e47036c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: George Angelopoulos <george@usermod.net>
+pkgname=tremc
+pkgver=0.9.1
+pkgrel=1
+pkgdesc="Curses interface for transmission - python3 fork of transmission-remote-cli"
+arch=('any')
+url="https://github.com/tremc/tremc"
+license=('GPL3')
+depends=('python')
+makedepends=('git')
+optdepends=('python-geoip: Guess which country peers come from'
+ 'python-xerox: Copy magnet links to the system clipboard')
+source=("https://github.com/tremc/tremc/archive/v0.9.1.tar.gz")
+md5sums=('08262de033014bf19cde91f1f27cf264')
+
+conflicts=('tremc-git')
+
+package() {
+ cd "$pkgname-$pkgver"
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+}
+
+# vim: ts=4 sts=4 sw=4 et