summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122022-04-07 19:40:19 +0200
committerwillemw122022-04-07 19:40:19 +0200
commitae640344163382d58c8429c8ee39138b71770578 (patch)
tree7ad4abf5d7180cad617acc1926339417eefb3543
parent8c41b22d49470fb8735ebd8c00d2729c1d977fd7 (diff)
downloadaur-ae640344163382d58c8429c8ee39138b71770578.tar.gz
Add provides, conflicts. Install settings.cfg ...
Change python-xerox to python-pyperclip. Change desc, optdepends desc, source, pkgver(). Remove cd.
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD27
2 files changed, 22 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8399e110a9d3..594f18431dc9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = tremc-git
- pkgdesc = Curses interface for transmission - python3 fork of transmission-remote-cli
- pkgver = r692.4d50dab
+ pkgdesc = Curses interface for Transmission. Python 3 fork of transmission-remote-cli
+ pkgver = 0.9.3.r0.g546fd09
pkgrel = 1
url = https://github.com/tremc/tremc
arch = any
license = GPL3
makedepends = git
depends = python
- optdepends = python-geoip: Guess which country peers come from
- optdepends = python-xerox: Copy magnet links to the system clipboard
- source = git+https://github.com/louipc/tremc.git
- md5sums = SKIP
+ optdepends = python-geoip: guess which country peers come from
+ optdepends = python-pyperclip: copy magnet links to the system clipboard (requires xclip)
+ provides = tremc
+ conflicts = tremc
+ source = tremc-git::git+https://github.com/tremc/tremc.git
+ sha256sums = SKIP
pkgname = tremc-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 9c00ced106da..aab6bb73fd55 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,28 @@
+# Maintainer: willemw <willemw12@gmail.com>
+# Contributor: sparse
+
pkgname=tremc-git
-_gitname=${pkgname%-git}
-pkgver=r692.4d50dab
+pkgver=0.9.3.r0.g546fd09
pkgrel=1
-pkgdesc="Curses interface for transmission - python3 fork of transmission-remote-cli"
+pkgdesc="Curses interface for Transmission. Python 3 fork of transmission-remote-cli"
arch=('any')
url="https://github.com/tremc/tremc"
license=('GPL3')
depends=('python')
makedepends=('git')
-optdepends=('python-geoip: Guess which country peers come from'
- 'python-xerox: Copy magnet links to the system clipboard')
-source=("git+https://github.com/louipc/tremc.git")
-md5sums=('SKIP')
+optdepends=('python-geoip: guess which country peers come from'
+ 'python-pyperclip: copy magnet links to the system clipboard (requires xclip)')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("$pkgname::git+$url.git")
+sha256sums=('SKIP')
pkgver() {
- cd "$_gitname"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git -C $pkgname describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
package() {
- cd "$_gitname"
-
- make PREFIX=/usr DESTDIR="$pkgdir" install
+ install -Dm644 $pkgname/settings.cfg -t "$pkgdir/usr/share/${pkgname%-git}"
+ make -C $pkgname PREFIX=/usr DESTDIR="$pkgdir" install
}
-# vim: ts=4 sts=4 sw=4 et