summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGötz2023-07-01 13:40:50 -0500
committerGötz2023-07-01 13:40:50 -0500
commita6a18e88bd81e78c1ce52bc8561d9c5b7c53f42c (patch)
treeb18cceae6a23c288cf8d27b29c47e43884badf92
parent62ae531473c8fdc75612f955768016324ccb9298 (diff)
downloadaur-a6a18e88bd81e78c1ce52bc8561d9c5b7c53f42c.tar.gz
Update Makefile
-rw-r--r--Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 6afe78a69228..6073b72eb45d 100644
--- a/Makefile
+++ b/Makefile
@@ -1,3 +1,9 @@
+.SHELL = /usr/bin/env bash
+
+NAME = "$(shell grep -m 1 pkgname .SRCINFO | cut -d '=' -f 2 | xargs)"
+URL = "$(shell grep url .SRCINFO | cut -d '=' -f 2 | xargs)"
+VERSION = "$(shell grep pkgver .SRCINFO | cut -d '=' -f 2 | xargs)"
+
.PHONY: all
all: build git install
@@ -29,7 +35,6 @@ git_add:
git add PKGBUILD .SRCINFO Makefile
.PHONY: git_commit
-git_commit: VERSION = "$(shell grep pkgver .SRCINFO | cut -d '=' -f 2 | xargs)"
git_commit: GIT_STATUS = "$(shell git status --porcelain)"
git_commit:
[ -n ${GIT_STATUS} ] && git commit -m "Update to ${VERSION}"
@@ -39,15 +44,13 @@ install:
makepkg --repackage --install --force
.PHONY: open
-open: URL = "$(shell grep url .SRCINFO | cut -d '=' -f 2 | xargs)"
open:
xdg-open $(URL)
.PHONY: run
-run: NAME = "$(shell grep -m 1 _name PKGBUILD | cut -d '=' -f 2 | xargs)"
run:
env $(NAME)
.PHONY: test
test:
- make run
+ env $(NAME) --version