summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRetro_Gamer2024-02-25 05:49:47 -0500
committerRetro_Gamer2024-02-25 05:49:47 -0500
commit505dba1cc337540599a672cf0a8fd8f85093366c (patch)
tree0892e84b001e3c54da3aa49a13eec43de8083e72
parent8f366d9be061d70ddd140873bdff46b913e28763 (diff)
downloadaur-trenchbroom-git.tar.gz
add makedepends/depends
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 39ffc76ab1f8..4f6e5d8ba536 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = trenchbroom-git
- pkgdesc = TrenchBroom is a modern cross-platform level editor for Quake-engine based games.
- pkgver = main_branch
+ pkgdesc = TrenchBroom is a modern cross-platform level editor for Quake-engine based games. This will build/install TrenchBroom from the current commits to the main branch of it's GitHub
+ pkgver = v2024.1.RC2.r19.gce15d1158
pkgrel = 1
url = https://trenchbroom.github.io/
arch = i686
@@ -14,6 +14,7 @@ pkgbase = trenchbroom-git
makedepends = qt5-svg
makedepends = libxcb
makedepends = zip
+ makedepends = unzip
depends = freeimage
depends = freetype2
depends = mesa
@@ -22,6 +23,7 @@ pkgbase = trenchbroom-git
depends = libxxf86vm
depends = glew
depends = glm
+ depends = tinyxml2
provides = trenchbroom
conflicts = trenchbroom
source = trenchbroom::git+https://github.com/TrenchBroom/TrenchBroom.git#branch=master
diff --git a/PKGBUILD b/PKGBUILD
index 1d793874714c..f8eaa405058b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,15 @@
# Contributor: Retro Gamer <https://github.com/eGax>
pkgname=trenchbroom-git
-pkgver=main_branch
+pkgver=v2024.1.RC2.r19.gce15d1158
pkgrel=1
-pkgdesc="TrenchBroom is a modern cross-platform level editor for Quake-engine based games."
+pkgdesc="TrenchBroom is a modern cross-platform level editor for Quake-engine based games. This will build/install TrenchBroom from the current commits to the main branch of it's GitHub"
arch=("i686" "x86_64")
url="https://trenchbroom.github.io/"
license=("GPLv3")
-makedepends=("git" "pandoc" "qt5-base" "cmake" "ninja" "qt5-svg" "libxcb" "zip")
-depends=("freeimage" "freetype2" "mesa" "libgl" "freeglut" "libxxf86vm" "glew" "glm")
+makedepends=("git" "pandoc" "qt5-base" "cmake" "ninja" "qt5-svg" "libxcb" "zip" "unzip")
+depends=("freeimage" "freetype2" "mesa" "libgl" "freeglut" "libxxf86vm" "glew" "glm" "tinyxml2")
conflicts=("trenchbroom")
provides=("trenchbroom")
@@ -49,4 +49,4 @@ package() {
cd "${srcdir}/$_BUILDDIR"
make DESTDIR="${pkgdir}" install
install -Dm644 "${srcdir}/trenchbroom/app/resources/linux/icons/icon_256.png" "${pkgdir}/usr/share/pixmaps/trenchbroom.png"
-}
+} \ No newline at end of file